none
.NET 4.6.1 on Windows Vista RRS feed

  • Question

  • According to this https://msdn.microsoft.com/en-us/library/bb822049(v=vs.110).aspx .NET 4.6 is supported on Windows Vista but 4.6.1 is not.  I've done some testing and was able to install the 4.6.1 framework on a Vista x64 VM and run a WinForms app compiled for 4.6.1 without issue.  Is there a reason Vista is not listed as supported for 4.6.1?
    Thursday, April 14, 2016 3:36 AM

Answers

  • Dear Steve,

    Welcome to the MSDN forum.

    The .NET Framework Version and Dependencies document describes our official support message about the .NET Framework and supported OS version, and the Vista version Mainstream Support End Date is 4/10/2012 which we can know it from https://support.microsoft.com/en-us/lifecycle/search?sort=PN&alpha=VISTA&Filter=FilterNO, maybe you can install .NET Framework 4.6.1 on Vista system, but for a better support of the usage of .NET Framework 4.6.1, we recommend you upgrade the system to Windows 7 or higher version, like Windows 10.

    Thank you for your understanding.

    Best regards,

    Sara



    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.


    Thursday, April 14, 2016 7:52 AM
    Moderator