locked
Stripped symbols doesn't appear to be stripped in VS2012 RRS feed

  • Question

  • When I use symchk to check on the stripped symbols (/ps), it reported that the symbol is not stripped. And using dbh to dump the info shows that the symbol is a private symbol.

    I.e.

    SYMCHK: MFCApplication1.exe  FAILED  - MFCApplication1.pdb is not stripped.

    DBGHELP: MFCApplication1 - private symbols

    I don't have this issue with VS2008, VS2010 butI can reproduce this error in VS2012 RTM/Update 2/3.

    Step to reproduce:

    1. Create a MFC project with VS2012

    2. Enable /DEBUG and set strip private symbol path for the stripped symbol

    3. Build the project

    4. Run symchk with /ps and it failed with symbol not stripped.

    Thanks.

    • Moved by Carl Cai Monday, October 14, 2013 2:04 AM get better support
    Friday, October 11, 2013 6:22 PM

All replies

  • Hi,

    Thanks for your posting.

    I am afraid that it may not be the correct forum for this issue, since it is relate to window desktop debug.

    I have moved this thread in dedicated Windows Desktop Debugging  forum for more dedicated  support.

    Thanks for your understanding.

    Regards.


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.


    • Edited by Carl Cai Monday, October 14, 2013 2:06 AM
    Monday, October 14, 2013 2:05 AM
  • I'm not sure if is appropriate in this Windows Desktop Debugging forum, caused the issue is not about debugging but rather on the Visual Studio 2012.

    As highlighted, strip PDBs generated by VS2012 is no longer seen as stripped today.

    Wednesday, October 23, 2013 1:54 AM
  • Hi Kenny Ong,

    where did you open this thread ? This is the Window Debugging Forum. Did you say symchk ? :)

    Otherwise where is the "in dedicated Windows Desktop Debugging" ?

    I try to reproduce your sepcified error in this thread, so I can give you feedback.

    Did you try Visual Studio 2013, perhaps it was fixed.

    Here two links what could be helpful:

    • Edited by sadolino Wednesday, October 23, 2013 3:24 PM
    Wednesday, October 23, 2013 3:21 PM
  • Hi sadolino,

    I opened this in Visual Studio Development since the issue is more created by the VS toolkit. Anyhow, VS2012 can reproduce the problem so you should be able to see the same error. I will give a try on VS2013.

    Thanks.

    Monday, October 28, 2013 8:12 AM
  • Hi again,i tried to reproduce this error from your post at the beginning. When i choose directly a name for the pdb file for the mfc project application then it works fine. But when i use the default values already integrated in the settings, then i get the same error. There is also an error when you set a path with no write permissions.I found some solutions to modify the $outdir variable perhaps you can solve it on this way.

    For "me" this setting is bugged because normally it should be created on the run when u choose debug option for the application to create a pdb file. I hope i could help u.


    • Edited by sadolino Wednesday, October 30, 2013 4:27 PM
    Wednesday, October 30, 2013 4:25 PM