none
Visual Studio 2015 sluggish while typing, slow when debuggin

    Question

  • As reported before VS is getting slower and slower with each release. I started developing with Microsoft Development Studio which was amazing fast and performant. I see a sharp decrease of performance with the latest iterations of Visual Studio. To the point that it gets annoying to work with. I've installed VS out of the box with no customization or plugins. 

    Is there a customization that makes VS faster? 

    I've got a Lenovo Carbon X1 with 8GB of wich currently 2.9 is reported free so I don't see a memory/thrashing problem. 

    Wednesday, November 25, 2015 9:50 AM

Answers

  • Hi theking2,

    You can try to update graphics drivers... Or the best way is to disable the hardware graphics acceleration in Visual Studio according to these simple steps:

    1. Visual Studio, go to Tools, and then Options.
    2. In Options, find to the Environment -> General section and clear/uncheck the Automatically adjust visual experience based on client performance check box.
    3. Clear/uncheck the Use hardware graphics acceleration if available check box.
    4. Select and Clear/uncheck the Enable rich client visual experience check box.

    Other way is to disable source control (if you are not using it) plug-in and set it to None (Tools > Options > Source Control), if you are using Microsoft Git provider, it seems to it's slow Visual Studio down more and more as larger the repository gets.

    Best regards!
    (If this was helpful for you, propose it as an answer)
    Wednesday, November 25, 2015 11:15 AM