locked
BUG: Code Coverage in VS11 does not update properly RRS feed

  • General discussion

  • This is a request for a bug submission. Admins, please move this topic to the appropriate place.

    Within my unit test, there is an "if" branch that matches. Execution branches to the proper region, but Code Coverage does not take notice, it still marks the lines as uncovered. If you need demo code, let me know, and I will forward my code to you.

    Kind regards,

    Carsten


    • Edited by CPosingies Saturday, September 1, 2012 6:16 PM
    • Changed type Forrest Guo Wednesday, September 19, 2012 9:13 AM OP discontinue
    Saturday, September 1, 2012 6:16 PM

All replies

  • Hello Carsten,

    Thank you for posting in the MSDN forum.

    Based on your description, I can’t understand your scenario clearly. So in order to repro your scenario and resolve your issue better, if possible, you could provide your demo code and more detailed information.

    In addition I would like to know which lines about the “if” branch that code coverage marked as uncovered after you run unit test.

    Best regards,


    Amanda Zhu [MSFT]
    MSDN Community Support | Feedback to us

    Monday, September 3, 2012 1:00 AM
  • Hello Carsten,

    What about your issue now? Have you resolved it?

    Can you give an example of what you are trying to do?

    Best regards,


    Amanda Zhu [MSFT]
    MSDN Community Support | Feedback to us

    Tuesday, September 4, 2012 3:00 AM
  • Hello, Amanda,

    I'm quite busy at the moment. But I'll keep this issue and this thread in my mind and will come back later with the demo code. Perhaps I'll have more information on how to reproduce the error then. If you like, you may close this thread for now. When I'm ready, I'll open a new one and refer to this.

    Regards,

    Carsten

    Wednesday, September 5, 2012 2:38 PM
  • If you are still experiencing this issue do you mind logging it as a visual studio connect bug here: https://connect.microsoft.com/VisualStudio

    This will help ensure it is properly tracked by the dev team responsible for the feature.


    Todd King - Visual Studio ALM team.

    Tuesday, October 9, 2012 1:18 AM
  • Hi Carsten

    What version of VS are you on? Could you please share the repro code with me (allendm-msft at hotmail dot com) so that I can have a quick look?


    Thank You
    Allen Mathias

    Tuesday, October 9, 2012 5:14 AM