none
Problem installing/removing/repairing .Net 1.0, 1.1, 2.0 RRS feed

  • Question

  • While trying to install Office 2007, I kept getting Error 1935.  One KB article suggested installing or repairing .Net 2.0.  Since that was not listed in Add/Remove Programs, I tried to install it.  
    That failed.
    I tried to repair .Net 1.0 and/or .Net 1.1, but in Add/Remove Programs I got a message saying, roughly, "You can only remove programs that are installed."
    How can I clean up the .Net Frameworks mess and start fresh?  I also have .Net 3.5 installed as well as VisStudio 2008.
    I have a .cab file of the log files after trying to install 1.1.  Is there a way to attach it to a forum message?

    TIA for any help...

    UPDATE:  I found this: http://blogs.msdn.com/astebner/pages/8904493.aspx, cleanup utilities for .Net.  Trying them, to see if they can help.
    Thursday, May 28, 2009 2:26 PM

All replies

  • Hi,

    What OS are you installing on?

    Did running the cleanup utility help?

    If not, please do let us know.

    When posting please follow the steps at the following blog post:

    http://blogs.msdn.com/aaronru/archive/2007/12/10/what-to-do-when-you-go-to-post-a-setup-and-deployment-issue-on-the-msdn-forums.aspx

    Thanks,
    Kanchan

    Thursday, May 28, 2009 11:17 PM
    Moderator
  • Thanks for the reply.

    WinXP sp 3.

    After researching the problem installing Office, it appeared my .Net 2.0 needed repair.  In trying to fix that, it seemed like the .Net 1.0/1.1 installs were corrupt, too.

    The cleanup tool appeared to work; it said it removed 1.0, 1.1, and 2.0 (separate operations).
    I reinstalled 1.0, 1.1, and 2.0 (from MS web sites).  Office apps still won't run -- Outlook, with message reported in OP, and Excel, with a message about starting in Safe mode, then "Not enough memeory to run Microsoft Office Excel."

    I just discovered that VisStudio 2008 won't run -- "Cannot find one or more components.  Please reinstall the application."

    I have the feeling that I'll need a full OS reinstall to fix this mess.  Pretty alarming that the OS can get in to this state...

    Thanks for any suggestions.
    Friday, May 29, 2009 11:51 AM
  • Hi,

    Were you able to resolve this issue? VS 2008 installs .Net 3.5 and I do not see the mention of the same above. Did you reinstall that as well?

    Thanks,
    Kanchan
    Saturday, June 6, 2009 9:30 AM
    Moderator