none
Esb Toolkit 2.1 import fails - problem with the Microsoft.Practices.ESB.Resolver.Itinerary assembly

    Question

  • I am trying to get the x64 version of the 2.1 ESB toolkit running.

    While importing or installing any of the msi packages I am getting this error:

    "Unable to register (biztalk) assembly resource with Luid "Microsoft.Practices.ESB.Resolver.Itinerary, Version=2.1.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" and source location "C:\Users\lars\AppData\Local\Temp\tmpD125\Assembly\92432d412d4d5cf08f75a714d365ebe1\Microsoft.Practices.ESB.Resolver.Itinerary.dll".

    A file load exception occurred while attempting to install the assembly into the Global Assembly Cache. This error may occur if the assembly is delay signed, or if assembly was renamed after creating/signing.

    Strong name signature could not be verified.  The assembly may have been tampered with, or it was delay signed but not fully signed with the correct private key. (Exception from HRESULT: 0x80131045)"

    Have anyone successfully gotten the 2.1 toolkit fully installed??


    Monday, May 24, 2010 4:04 PM

Answers

All replies

  • I looked at the assembly in the MSI and it differs from the one in the BIN folder.

    BIN:
    size: 22936 bytes
    mod: 2010-05-13 13:08:14

    MSI:
    size: 16896 bytes
    mod : 2010-05-13 16:03:22

    "sn.exe -V" confirms the error message that it´s a delay signed assembly present in the MSI.

    I can install this 'delay signed' version with gacuil after i have made a "sn.exe -Vr" but it does not make a difference to the error when importing the MSI. I guess i will add the resources manually from BIN folder until an updated MSI is released.


    magohl
    Monday, May 24, 2010 10:13 PM
  • Hi Magnus,

    Thats a good and solid solution. But I've got too many other things to do right now, So I'll wait for them to fix the MSI package. I'm guessing a refresh will come out since a lot of people should be hitting this.

    Thanks 

    Lars

    Tuesday, May 25, 2010 5:50 PM
  • Hi Magnus,

     

    we work very hard, every day with ESB 2.0, and we want try this ESB version, when you release  the correct MSI? We are expecting for work with the entire BizTalk, adapters, his, etc.

    Help us. Thanks

    Marco Antonio

    iT Synergy

    Tuesday, May 25, 2010 10:27 PM
  • Hi Marco,

    I don't think Magnus is with Microsoft, so don't expect him to fix your problems or release a new version of the Toolkit Biztalk installers.  :-)

    BUT ... what he wrote up should work, so just go with that if you want to testdrive the 2.1 Beta.

     

     

    Tuesday, May 25, 2010 10:58 PM
  • I've set all assemblies using 'sn -Vr *'

    I've removed all relevant 2.1 assemblies from the GAC using 'gacutil /ul assemblyList.txt'

    I reinstalled all 2.1 assemblies into the GAC using 'gacutil /il assembyList.txt'.

    At this point, I did not re-attempt an import, since this would only re-generate the 'late signing' exception.  (BTW, I've tried it both ways already.)

    I'm still unable to compile the DynamicResolution due to missing vocabulary.

    If I try to import the CORE.msi at this point, the exception complains about the late signing on Resolver.Facts.  I cannot complete the import function no matter what I try.

    I've been working on this issue, using workarounds, for a week.  Now it's time to ask for step-by-step help.  Thanks in advance.

    richard

    Tuesday, June 01, 2010 4:55 PM
  • Thanks fastjets99.  I too am experiencing the same error while importing the CORE.msi.  We need a resolution from Microsoft as registering the assemblies does not install the required BizTalk Server artifacts (vocabularies, pipelines, etc).
    Tuesday, June 01, 2010 7:51 PM
  • Yeah ... they should get it fixed. I couldn't find a channel for the 2010 beta on Connect, so I don't  know where to log this as an error.  

    I am surprised that we are the only ones writing about it in this thread. I would have thought more ppl was interested in getting this fixed!?

    Tuesday, June 01, 2010 8:12 PM
  • I submitted an issue on the BizTalk ESB Toolkit Connect site.  I may try to get in touch with someone personally at MS.  Since it's just a delayed signing issue it doesn't seem like it would be too big of a fix.

    https://connect.microsoft.com/site886/feedback/details/564759/esb-toolkit-2-1-beta-core-msi-import-fails

     

    Wednesday, June 02, 2010 1:28 PM
  • We have a fix ready for this blocking issue. We will be posting the updated product MSI with the fix on the download center soon.

    Stay tuned for my next announcement when the the updated MSI is available for download.

    -vinay

    Program manager for ESB Toolkit

    • Proposed as answer by Mat Giaimo Wednesday, June 02, 2010 8:46 PM
    Wednesday, June 02, 2010 2:12 PM
    Moderator
  • Do you have a date when this is likely to be released?
    Friday, June 04, 2010 12:43 PM
  • Hey, the updated ESB release came out a few days ago. Just updating this thread the update is on the Connect site under the downloads.

    Thanks,


    If this answers your question, please use the "Answer" button to say so | Ben Cline
    • Proposed as answer by Mat Giaimo Thursday, June 10, 2010 1:33 PM
    Wednesday, June 09, 2010 9:30 PM
    Moderator
  • Can someone post the link to the updated files.  I can't seem to find it.

    Thanks

    Tom

    Thursday, June 10, 2010 3:09 PM
  • It looks like the update has not made it to microsoft.com/download. I will ask the BizTalk team if they can move it there too.

    Thanks,


    If this answers your question, please use the "Answer" button to say so | Ben Cline
    Thursday, June 10, 2010 3:50 PM
    Moderator
  • Thanks Ben
    Thursday, June 10, 2010 4:10 PM
  • The updated MSI with the fix is now available on download center as well

     

    http://www.microsoft.com/downloads/details.aspx?FamilyID=0f852e77-f792-4784-b2d4-95113d40db64&displaylang=en

     

    -vinay

    Program manager for ESB Toolkit

    Friday, June 11, 2010 11:38 PM
    Moderator
  • I used the latest MSI and still ran into "Strong name validation failed" for 2 assemblies

    Microsoft.Practices.Services.Extenders.Resolvers.WsMex

    .dll

    Microsoft.Practices.Services.Extenders.Itinerary.OffRamp.dll

     

    I had to do the sn -Vr to get it to work

    Monday, August 02, 2010 6:46 PM