none
Call WebService from Biztalk Orchestration RRS feed

  • Question

  •  

    Hi All..

    I am working on project where i need to update MOss 2007 form library..to do this i need to call webservice because MOSS 2007 is installed on other server ..so what i am doing right now that i have added web reference to that webservice and in expression edition made new object  and calling that webservice..but its giving HTTP 401 authorisation error ..

    Can anyone pls tell me correct procedure to call webservice...

     

    Thanks

    Sandeep

     

    Friday, July 18, 2008 6:30 AM

Answers

  • Hi,

     

    If you are using BizTalk Server 2006 R2, with .net 3.0 installed, you should try using the WCFBasicHttp adapter and adding a WCF service, rather than using the SOAP adapter and Add Web Reference. The WCF adapters offer much more configuration options and seem to work better than the SOAP adapter.

     

    Regards,

     

    Alan

     

     

     

    Sunday, July 27, 2008 9:15 PM

All replies

  • It sounds like you are trying to call a web service on the MOSS Server. Is this correct? If so, are you calling one of the MOSS admin web services or a custom one? If it is a custom one, you will need to configure MOSS's managed paths so that MOSS does not filter the service out. There is also some other configuration to do in order to enable the MOSS service to expose the service appropriately. Here is a good article that explains some of the complexities of the web service to MOSS configuration process - http://it.toolbox.com/blogs/sharepoint-blog/creating-a-custom-web-service-for-sharepoint-13553.

     

    Thanks,

    Thursday, July 24, 2008 4:18 PM
    Moderator
  • Hi,

     

    If you are using BizTalk Server 2006 R2, with .net 3.0 installed, you should try using the WCFBasicHttp adapter and adding a WCF service, rather than using the SOAP adapter and Add Web Reference. The WCF adapters offer much more configuration options and seem to work better than the SOAP adapter.

     

    Regards,

     

    Alan

     

     

     

    Sunday, July 27, 2008 9:15 PM