none
Error in ESBConfigurationTool RRS feed

  • Question

  • Hello

    I Have a problem installing “Microsoft BizTalk ESB Toolkit 2.0”, when executing the application “ESBConfigurationTool” to configure services and components, I’m getting the error “The server could not be contacted” for the item “Exception  Web service”.

    I am using:
       Windows Server 2008
       BizTalk Server 2009
       BizTalk ESB toolkit 2.0
       SQL server 2008

    Thanks for your help.

    Alejandro Gonzalez

    Thursday, June 18, 2009 8:04 PM

Answers

  • Is this a local account or a domain account you are using to configure the service with?  If not a local account, can you go into the configuration file for the ESB config tool and change the default accounts from the local group to the domain account?  Let me know if this fixes the issue.

    Thanks,
    Brendon Birdoes
    Tuesday, June 23, 2009 4:57 PM
    Moderator
  • My previous post was not as descriptive as it could have been.  Please go to this location: C:\Program Files\Microsoft BizTalk ESB Toolkit 2.0\Bin assuming you used the default installation path.    Open the file ESBConfigurationTool.exe.config in a text editor and modify the various BizTalk groups to the domain groups that you would like to use.  For example:

    <add key="BizTalkAdminGroup" value="WIN2K8-SVC\BizTalk Server Administrators" />

    Change To:

    <add key="BizTalkAdminGroup" value="mydomain\BizTalk Server Administrators" />

    Run the tool again and let me know if the configuration of the environment works. 

    Thanks,


    Brendon Birdoes
    Thursday, June 25, 2009 4:51 AM
    Moderator

All replies

  • Have you validated that IIS is up and running correctly?  Also do you have any other web sites set up?  Can you also look in the EsbConfigurationTool.log file for more details?  This resides in the same folder as the configuration tool.

    Thanks,


    Brendon Birdoes
    Friday, June 19, 2009 4:13 AM
    Moderator
  • Thanks Brendon Birdoes

    In the EsbConfigurationTool.log file is recorded the following error:

     

    ESBConfigurationTool.exe Information: 0 : Executing script: databaseExistsSmoIntegrated.ps1 in view: ExceptionManagementDatabase with parameters: Key: serverInstance Value: c-BizTalk, Key: databaseName Value: EsbExceptionDb,

     

    ESBConfigurationTool.exe Information: 0 : The server could not be contacted.

     

    ESBConfigurationTool.exe Error: 0 : An error has occurred:

     

    The server could not be contacted.

     

    The LDAP server is unavailable.

     

    Stack Trace:

       at System.DirectoryServices.AccountManagement.PrincipalContext.ReadServerConfig(String serverName, ServerProperties& properties)

       at System.DirectoryServices.AccountManagement.PrincipalContext.DoServerVerifyAndPropRetrieval()

       at System.DirectoryServices.AccountManagement.PrincipalContext..ctor(ContextType contextType, String name, String container, ContextOptions options, String userName, String password)

       at System.DirectoryServices.AccountManagement.PrincipalContext..ctor(ContextType contextType, String name)

       at EsbConfigurationTool.Panels.PanelBase.ValidateCredential(NetworkCredential credentials, String groupName)

       at EsbConfigurationTool.Panels.WebServicesException.Save()

       at EsbConfigurationTool.EsbConfiguration.OnTsBtnSaveClick(Object sender, EventArgs e)

     

    Alejandro Gonzalez

     

    Friday, June 19, 2009 1:51 PM
  • Is this a local account or a domain account you are using to configure the service with?  If not a local account, can you go into the configuration file for the ESB config tool and change the default accounts from the local group to the domain account?  Let me know if this fixes the issue.

    Thanks,
    Brendon Birdoes
    Tuesday, June 23, 2009 4:57 PM
    Moderator
  • Thanks Brendon Birdoes

     

    In the ESBConfigurationTool I added a local account and it worked fine, but I need to use a domain account.

     

    Alejandro Gonzalez.

    Wednesday, June 24, 2009 8:13 PM
  • My previous post was not as descriptive as it could have been.  Please go to this location: C:\Program Files\Microsoft BizTalk ESB Toolkit 2.0\Bin assuming you used the default installation path.    Open the file ESBConfigurationTool.exe.config in a text editor and modify the various BizTalk groups to the domain groups that you would like to use.  For example:

    <add key="BizTalkAdminGroup" value="WIN2K8-SVC\BizTalk Server Administrators" />

    Change To:

    <add key="BizTalkAdminGroup" value="mydomain\BizTalk Server Administrators" />

    Run the tool again and let me know if the configuration of the environment works. 

    Thanks,


    Brendon Birdoes
    Thursday, June 25, 2009 4:51 AM
    Moderator
  • I ran the configuration tool "ESBConfigurationTool" like you told me and it works perfect.

    Thanks Brendon Birdoes

    Alejandro Gonzalez J.

    Saturday, June 27, 2009 2:40 PM