locked
VS 2010 SP1 Lightswitch 2011 trial SQL Server 2014 RRS feed

  • Question

  • I am new to Lightswitch and trying to understand how to develop.

    With the above combination of products, I get an error (local computer)

    Error 1 Sql Server version not supported 12.00.2000 C:\Program Files (x86)\MSBuild\Microsoft\VisualStudio\LightSwitch\v1.0\Microsoft.LightSwitch.targets 157 10 Application1

    I tried a server running SQL Server 2008 R2 Sp4 as the database source and still get the same error.

    In home, I have a SQL server 2012 and VS 2010 SP1 and Lightswitch 2011 trial. Here I can run the program.

    Does VS 2010 & LS 2011 support SQL 2014 express editions? Any solution. 

    Saturday, February 13, 2016 12:01 PM

Answers

  • Hi Alan & Eric

    I wanted to explore more about the problem and found a different kind of solution.

    1. Removed SQL 2014 express

    2. Installed SQL 2008 R2 SP4.

    3. Tested in Lightswitch. Different error came "An error occurred while establishing a connection to SQL Server instance '.\SQLEXPRESS'. Failed to generate a user instance of SQL Server due to a failure in starting the process for the user instance. The connection will be closed"

    4. Searched the forums and the solution was to remove the contents from  C:\Users\<users>\AppData\Local\Microsoft\Microsoft SQL Server Data\SQLEXPRESS

    5. Restart MS SQL services.

    6. Now the Lightswitch project can be compiled without any errors and we can see the screens generated.

    In order to which version of SQL server can be used, I upgraded 2008 to 2012 and 2014 and in these cases, it fails to compile with the original error.

    So to conclude, Vs2010, Sql 2008 Sp4 and Lightswitch 2011 is the combination to stick to.

    Of course, one can use the Vs 2015 and higher versions of sql and LS.

    • Marked as answer by kesk Tuesday, February 16, 2016 11:07 AM
    Tuesday, February 16, 2016 11:07 AM

All replies

  • Hi Kesk

    I seem to recall that LS only supports SQL Server 2014 from one of the VS2013 service packs onwards.

    Cheers

    Alan


    VFP9Belgium

    Saturday, February 13, 2016 12:27 PM
  • I think it's better to upgrade to VS Community 2015 then you have less trouble and Community is Free!

    Enjoy!


    Eric

    • Proposed as answer by Eric.Luitjens Saturday, February 13, 2016 11:08 PM
    Saturday, February 13, 2016 11:07 PM
  • Hi Alan & Eric

    I wanted to explore more about the problem and found a different kind of solution.

    1. Removed SQL 2014 express

    2. Installed SQL 2008 R2 SP4.

    3. Tested in Lightswitch. Different error came "An error occurred while establishing a connection to SQL Server instance '.\SQLEXPRESS'. Failed to generate a user instance of SQL Server due to a failure in starting the process for the user instance. The connection will be closed"

    4. Searched the forums and the solution was to remove the contents from  C:\Users\<users>\AppData\Local\Microsoft\Microsoft SQL Server Data\SQLEXPRESS

    5. Restart MS SQL services.

    6. Now the Lightswitch project can be compiled without any errors and we can see the screens generated.

    In order to which version of SQL server can be used, I upgraded 2008 to 2012 and 2014 and in these cases, it fails to compile with the original error.

    So to conclude, Vs2010, Sql 2008 Sp4 and Lightswitch 2011 is the combination to stick to.

    Of course, one can use the Vs 2015 and higher versions of sql and LS.

    • Marked as answer by kesk Tuesday, February 16, 2016 11:07 AM
    Tuesday, February 16, 2016 11:07 AM