none
Install of .NET 2.0 sp1 hangs on mscoree.dll RRS feed

  • Question

  • I am completely stuck trying to get all .NET versions installed up to 3.5. I received a laptop from my work with the 'image' they deploy. It included .NET 2.0, but for my work I need newer .NET versions.

    I proceeded to install .NET 3.0sp1 and it hung. I then tried to 'repair' .NET 2.0 thinking there may be some issue there and it refused to run the repair, giving an error and exiting the repair process. I even was not able to uninstall .NET 2.0.

    I then used the .NET uninstall tool that everyone talks about and was able to remove all versions of .NET. I then installed .NET 1.1 and SP1 successfully.

    I'm now trying to install .NET 2.0 and it simply will not complete the process and hangs.

    I've tried uninstalling and reinstalling many times. I've logged in with my domain account (who has local admin rights) as well as the local admin account. Both fail the same way.

    I've tried installing the separate NetFx20SP1_x86.exe as well as jumping right up to dotnetfx35setup.exe. Both are failing exactly the same way during the installation of .NET 2.0. It just hangs -- I left it running overnight and still hung at the same place.

    I've looked at the log file in temp: dd_NET_Framework20_Setupxxxx.txt and always the file ends with the same last line:

    DD_Status: CustomActionData: mscorlib...
    DD_Status: Loading mscoree.dll

    That's it, it just sits there forever. If I look in Add/Remove programs, it does not show .NET 2.0 as being installed. If I run the uninstall tool and look at the logs, it shows that .NET 2.0 is present, so I guess it's 99% of the way done.

    I've searched through forums and tried just about everything I could find that seems relevent to my issues. I've used the config tool to turn off all non-microsoft services, disabled AV, cleared temp folders, logged in as different admin users.

    Any suggestions for how to figure this out would be much appreciated!

    Thanks!
      Dane
    Thursday, February 18, 2010 1:57 PM

Answers

  • Hi Dane,

    Welcome to MSDN forums.

    Based on your description, it seems that you're running Windows XP, right?

    For your concern, I would suggest you to try installing .NET Framework 3.5 which will also install .NET Framework 2.0 and 3.0 as prerequisite.

    Please try the following steps for further troubleshooting:

    1. Use Cleanup tool to clear the failed installation of .NET Framework 3.0 >> 2.0 in order
    2. Rename the file %windir%\system32\mscoree.dll. Also, please take note of what the version of this file is to aid in tracking down why this error is occurring.
    3. Download .NET Framework 3.5 Service Pack 1 (Full Package) and install it
    4. If any problem occurs during the installation, use Collect tool to collect the log files for further troubleshooting.

    - Try to clean your "%temp%" folder (Start Menu >> Run >> Type "%temp%")
    - Install .NET Framework 3.5 with SP1
    - Collect the logs from "%temp%" folder
      Collect tool: http://blogs.msdn.com/heaths/archive/2008/05/09/visual-studio-and-net-log-collection-utility.aspx
    - Send vslogs.cab file to me (v-yicche@microsoft.com)
      Note: Please attach the link of this post in the mail.

    Hope this helps! If you have any concern, please feel free to let me know.

    Best regards,
    Yichun Chen


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    • Edited by YiChun Chen Friday, February 19, 2010 8:09 AM typo
    • Marked as answer by YiChun Chen Thursday, February 25, 2010 2:18 AM
    Friday, February 19, 2010 8:08 AM