none
GraphEdit error 0x80004002 when playing webcam on WES7 with UAC on RRS feed

  • Question

  • I have made an installation with Windows 7 Embedded Standard Sp1 (evalluation version).

    In GraphEdit I made a graph for capturing and rendering video from a USB-webcam.

    As administrator-user and UAC disabled, this graph plays and displays the video from the webcam.

    With UAC enabled running the graph gives an 0x80004002 error.

    On my desktop-PC with Windows 7 such a graph with problems as standard-user and UAC enabled.

    How to display webcam-video on my WES7 installation, for a standard user and UAC enabled?

    Is  there something missing in my WES7 installation? (As defined in the answer file configured with Image Confugration Editor.)

    Wednesday, May 30, 2012 7:57 AM

All replies

  • This one could be searching for a needle in a haystack. Did you build a full OS image or a smaller custom one?

    -Sean


    www.sjjmicro.com / www.seanliming.com / www.annabooks.com, Book Author - Pro Guide to WES 7, XP Embedded Advanced, Pro Guide to POS for .NET

    Wednesday, May 30, 2012 9:01 PM
    Moderator
  • I am searching already a complete week this needle, because it must be found.

    It is almost a full OS image, but without MediaCenter, "Data Access and Storage" and "Embedded Enabling Features".

    -Joost

    Thursday, May 31, 2012 7:20 AM
  • What about driver packages?

    -Sean


    www.sjjmicro.com / www.seanliming.com / www.annabooks.com, Book Author - Pro Guide to WES 7, XP Embedded Advanced, Pro Guide to POS for .NET

    Thursday, May 31, 2012 12:29 PM
    Moderator
  • Enough driver packages to let it work for administrator-user and UAC off.

    Driver packages:

    61883, Avc, Bluetooth, Digitalmediadevices, Display, Dot4, Hidclass, Images, Keyboard, Media, Mediacenterextenders, Net, Netservice, Printer (3 drivers), Scsiadapter, Sensor, smartcard, Smartcartfilter, System, Usb and Wpd.

    -Joost

    Thursday, May 31, 2012 1:15 PM
  • All the WDM-devices failed to work in GraphEdit with UAC on.

    e.g. :
    Audio Capture Sources > Microphone (USB Audio Device) : is working.
    WDM Streaming Capture Devices > USB Audio Device : is failing.

    -Joost

    Friday, June 1, 2012 1:01 PM
  • HI,

    I have exactly the same problem, driver is ok on device manager, webcam is display on Video Capture Source (graphedit).

    I can insert webcam filter and render pin (to add video renderer ) but when i play : 0x80004002 - Interface not supported.

    - Please help -

    Friday, December 14, 2012 3:17 PM