none
Inserting clob data to Oracle problem. RRS feed

  • Question

  • I'm trying to insert clob data which is around 250K through stored
    procedure in oracle. But I'm getting 'ORA-1460: unimplemented or
    unreasonable conversion'.
      I tried to find solution on internet but I still can't find any solution.
    PS. I uses .NET Framework 1.2


    Any help is appreciated.

    Regards,
    Yang
    Tuesday, March 18, 2008 4:15 AM

Answers

All replies

  • This is more of an oracle issue than a C# issue. From what I've found, it appears that Oracle has an issue inserting more than 32k, unless specific flags are set. I'd ask on an oracle forum, like this one.

     

    Tuesday, March 18, 2008 5:30 AM
  • I thinks it's C# and Oracle integration problem because I can send big string to oracle directly but I can't send the same message via C# to oracle.

    Thank for your suggestion,
    Yang.
    Tuesday, March 18, 2008 6:00 AM
  • I've found people refering to the same error, coding in Java and C/C++, so it make me think it isn't a C# issue Smile

     

    Tuesday, March 18, 2008 12:27 PM
  • Yes, I found this problem when I coded with java too but It doesn't throw the same error that I found this time.
    When I coded with java, I can solve this solution by update JDBC or send addition configuration when I open connection.
    After I solved that problem, I can send very long text from java to oracle stored procedure.
    But I can't find any solution for this problem for C# programming.
    Tuesday, March 18, 2008 12:37 PM
  • Oracle have fixed the problem but you must use ODP.NET to use up to 2gig in blob file, they introduced a location based class to let you use up to 2gig in clob file.  Check the thread below for details.

     

    http://forums.microsoft.com/MSDN/ShowPost.aspx?PostID=2949620&SiteID=1

     

    Tuesday, March 18, 2008 4:44 PM