none
BizTalk 2009: SMTP Adapter setting used HELO hostname RRS feed

  • Question

  • Hi everybody,

    I'm trying to send a notification email via the SMTP adapter in BizTalk Server. Now that works as expected with mail servers that are not configured strictly. Many of them however rightfully expect a FQDN when issuing HELO/EHLO commands to weed out some spam. Now my server however, which is running BizTalk, does have a server name which is not a FQDN (for example "BIZTALK"). Now the SMTP adapter uses this name and sends "HELO BIZTALK", which will be declined...

    How can I set the hostname used for HELO when using the SMTP adapter?

     

    I tried setting the primary DNS suffix in the computer name settings, but as far as I can tell, that only should be relevant for hostname resolving and therefore doesn't affect the HELO command at all. On the other hand, changing the computer name after I've installed BizTalk and SQL Server is not a great idea, as it results in stuff not working anymore, so that isn't an option (manually changing those settings in SQL Server is quite error prone).

     

    Thank you in advance, any help is highly appreciated.

    Greetings...

    Thursday, August 5, 2010 10:08 AM

Answers

  • Hi,

    There is a hotfix for allowing the configuration of the FQDN when using System.Net.Mail namespace.  It depends on how BizTalk internally implementated the SMTP client. (i.e. did they use System.Net.Mail namespace)

    http://support.microsoft.com/kb/957497/

    Note: You would add the changes noted in the hotfix to your machine.config file.

    Thanks,

    William

    Tuesday, August 10, 2010 5:06 PM