locked
App Service Installation on ASDK cant connect to Product Feed. RRS feed

  • Question

  • How does the App Service Installer try to connect to the Product Feed?  I have an ASDK deployment that I am able to get to portal.azure.com from.  I am able to register the Stack with my Azure tenant.  I can download images from the Marketplace.  However, when I run the App Service installer I get an error that the App service installer was unable to reach the product feed.  Please install from a machine with internet access or create an offline installation package.....

    I have tried to find how the installer is trying to communicate with the product feed but I can't find this information.  What protocol and what port does the installer try to use?  I would assume if it tried 80/443 that I wouldn't run into this issue.  This specific box has had all previous releases of the ASDK deployed with no issues when trying to run the App Service Installer. 


     

    Kristopher Turner | Not the brightest bulb but by far not the dimmest bulb.

    Monday, March 12, 2018 3:08 AM

Answers

  • Hi,

        apologies for the inconvenience you have been caused.  We had to remove the links to the release due an issue identified last week.  Therefore the installer and product feed links were disabled.  We reach out to the product feed over https (443) so you would have been good.

    The new release will be available at 10am pacific today, please refer to documentation updates and download the new installer and helper scripts from:  https://docs.microsoft.com/en-us/azure/azure-stack/azure-stack-app-service-before-you-get-started 

    Thanks

    Andrew


    Andrew Westgarth | Program Manager II Azure App Service Blog: http://www.andrewwestgarth.co.uk/blog Twitter: http://www.twitter.com/apwestgarth


    Monday, March 12, 2018 3:44 PM
  • Kristopher,

    I've verified that App Service product feed is now back up and working correctly.

     Thanks,


    Gary Gallanes

    Monday, March 12, 2018 7:37 PM

All replies

  • Hi,

        apologies for the inconvenience you have been caused.  We had to remove the links to the release due an issue identified last week.  Therefore the installer and product feed links were disabled.  We reach out to the product feed over https (443) so you would have been good.

    The new release will be available at 10am pacific today, please refer to documentation updates and download the new installer and helper scripts from:  https://docs.microsoft.com/en-us/azure/azure-stack/azure-stack-app-service-before-you-get-started 

    Thanks

    Andrew


    Andrew Westgarth | Program Manager II Azure App Service Blog: http://www.andrewwestgarth.co.uk/blog Twitter: http://www.twitter.com/apwestgarth


    Monday, March 12, 2018 3:44 PM
  • Thank you, Andrew. 

    Kristopher Turner | Not the brightest bulb but by far not the dimmest bulb.

    Monday, March 12, 2018 3:58 PM
  • Kristopher,

    I've verified that App Service product feed is now back up and working correctly.

     Thanks,


    Gary Gallanes

    Monday, March 12, 2018 7:37 PM
  • It looks good now. 

    Thank you.


    Kristopher Turner | Not the brightest bulb but by far not the dimmest bulb.

    Tuesday, March 13, 2018 2:09 AM