none
extraction failed/operation successfully completed RRS feed

  • Question

  • When run program from microsoft packed in sfx cab (NetFx20SP2_x86.exe, scripten.exe, etc.) comes out error
    "Extraction failed" "The operation completed successfully."
    All rights to installer checked belong to the Administrators group.
    Create a new user with Admin rights, are not help.
    safe mode does not help.
    attempt to unpack and run also did not work.
    from the command line gives the same error.
    attempt to reinstall ie8, the same error.
    Tuesday, December 25, 2012 2:15 PM

Answers

  • Because your error is not explained by your install logs, and this situation:

    [12/25/12,21:45:04] Install state for .NET Framework 2.0: installed with no service packs.
    [12/25/12,21:45:04] Install state for .NET Framework 3.0: installed with service pack 2.
    [12/25/12,21:45:04] Install state for .NET Framework 3.5: installed with service pack 1.

    indicates an issue with your .NET 2.0, I suggest that you consider uninstalling .NET 3.5, then .NET 3.0, then .NET 2.0 and reinstalling from scratch.

    Use this cumulative installer for .NET 2.0/3.0/3.5 with all updates through 3.5 SP1:

    http://download.microsoft.com/download/2/0/e/20e90413-712f-438c-988e-fdaa79a8ac3d/dotnetfx35.exe

    Wednesday, December 26, 2012 2:40 PM

All replies

  • Please share your Windows version and Service Pack level.

    From the information you've provided, the failure appears to be when trying to extract SP2 for .NET Framework 2.0. Please show the URL where you downloaded the file you are trying to install.

    Also, use this tool to identify and verify the .NET Frameworks currently installed on your system:

    http://blogs.msdn.com/b/astebner/archive/2008/10/13/8999004.aspx

    Run the tool with .NET Framework 2.0 selected, then post the first 15 lines AND the LAST 15 lines of the tool log here.

    It will also help if you provide complete install logs as follows:

    Please collect your install logs with this:

    http://aka.ms/vscollect

    After you run Collect.exe, you'll find vslogs.cab in your %temp% directory. Please upload vslogs.cab to a public site, like SkyDrive, and post the link here.

    Tuesday, December 25, 2012 3:21 PM
  • Windows 2003 SP2

    downloaded from http://www.microsoft.com/en-us/download/details.aspx?id=1639

    At first as with other files packed in sfx cab wrote error "the installation program appears to be damaged or corrupted ..." After unpacking, run netfx_setupverifier.exe all went well

    first 15 lines

    ======================================================================
    [12/25/12,21:45:04] Beginning of new SetupVerifier activity logging session
    [12/25/12,21:45:04] Activity log file location: C:\Users\ADMINI~1.000\LOCALS~1\Temp\setupverifier_main_12-25-12_21.45.04.txt
    [12/25/12,21:45:04] Error log file location: C:\Users\ADMINI~1.000\LOCALS~1\Temp\setupverifier_errors_12-25-12_21.45.04.txt
    [12/25/12,21:45:04] Build created on September 10, 2012
    [12/25/12,21:45:04] Detected operating system: Windows Server 2003 (x86)
    [12/25/12,21:45:04] For more information about repairing the .NET Framework, see http://support.microsoft.com/kb/2698555 and http://go.microsoft.com/fwlink/?LinkID=246062
    [12/25/12,21:45:04] Install state for .NET Framework 1.0: not installed.
    [12/25/12,21:45:04] Install state for .NET Framework 1.1: installed with service pack 1.
    [12/25/12,21:45:04] Install state for .NET Framework 2.0: installed with no service packs.
    [12/25/12,21:45:04] Install state for .NET Framework 3.0: installed with service pack 2.
    [12/25/12,21:45:04] Install state for .NET Framework 3.5: installed with service pack 1.
    [12/25/12,21:45:04] Install state for .NET Framework 4 Client: not installed.
    [12/25/12,21:45:04] Install state for .NET Framework 4 Full: not installed.
    [12/25/12,21:45:04] Install state for .NET Framework 4.5: not installed.

    Last 15 lines

    [12/25/12,21:45:12] FriendlyName = '.NET Framework 2.0 test application'
    [12/25/12,21:45:12] TimeoutSeconds = '300'
    [12/25/12,21:45:12] WaitOnExit = 'true'
    [12/25/12,21:45:12] Silent = 'true'
    [12/25/12,21:45:12] Launching process 'Netfx20TestApplication.exe' now
    [12/25/12,21:45:12] Process successfully launched. Waiting 300 seconds for it to complete.
    [12/25/12,21:45:13] Process 'Netfx20TestApplication.exe' exited with return code 0
    [12/25/12,21:45:13] Section [Files - .NET Framework netfxperf.dll] - start parsing entries
    [12/25/12,21:45:13] File C:\WINDOWS\system32\netfxperf.dll (version 1.1.4322.573) is installed on the system
    [12/25/12,21:45:13] Section [Files - .NET Framework netfxperf.dll] - stop parsing entries
    [12/25/12,21:45:13] Verification succeeded for product .NET Framework 2.0
    [12/25/12,21:45:17] Launching process 'change user /execute' now
    [12/25/12,21:45:17] Process successfully launched. Waiting 4294967 seconds for it to complete.
    [12/25/12,21:45:17] ****ERROR**** Process 'change user /execute' exited with return code 1
    [12/25/12,21:45:17] SetupVerifier exiting with return value 0


    there all files https://skydrive.live.com/redir?resid=1DAA094B651C9E0B!105
    Tuesday, December 25, 2012 6:05 PM
  • Because your error is not explained by your install logs, and this situation:

    [12/25/12,21:45:04] Install state for .NET Framework 2.0: installed with no service packs.
    [12/25/12,21:45:04] Install state for .NET Framework 3.0: installed with service pack 2.
    [12/25/12,21:45:04] Install state for .NET Framework 3.5: installed with service pack 1.

    indicates an issue with your .NET 2.0, I suggest that you consider uninstalling .NET 3.5, then .NET 3.0, then .NET 2.0 and reinstalling from scratch.

    Use this cumulative installer for .NET 2.0/3.0/3.5 with all updates through 3.5 SP1:

    http://download.microsoft.com/download/2/0/e/20e90413-712f-438c-988e-fdaa79a8ac3d/dotnetfx35.exe

    Wednesday, December 26, 2012 2:40 PM
  • Ok, I deleted all NET => downloaded dotnetfx35.exe. But when try start setup I get the same error "extraction failed"
    Monday, January 7, 2013 9:21 AM
  • Check your downloaded dotnetfx35.exe against these checksums:

    MD5 = d481cda2625d9dd2731a00f482484d86

    SHA1 = 3dce66bae0dd71284ac7a971baed07030a186918

    If your values do not match, your download is corrupt.

    If the values DO match, try a manual extraction of the self-extracting archive.

    In the extraction, you'll find\dotnetfx35.exe\wcu\.\.\.\.\.\dotNetFramework\dotNetFx35setup.exe

    Try running the setup.

    Monday, January 7, 2013 6:33 PM
  • I checked the checksums, tried to unpack and start dotnetfx35setup.exe but got the same error(((

    Tuesday, January 8, 2013 11:36 AM
  • Do you have any other suggestions that I can do with this error?
    Thursday, January 17, 2013 7:32 PM
  • In your situation, I'd be considering an OS reinstall. I realize this sounds like a brute force approack, but that's what I would do.

    If you need expert advice specific to server OS repair/reinstall, you should ask in the Windows Server forums, here:

    http://social.technet.microsoft.com/Forums/en/category/windowsserver/

    Friday, January 18, 2013 4:18 PM
  • Thanks for your response.

    Reinstalling is the last thing I do. But thanks anyway.

    Thursday, January 24, 2013 5:34 AM