none
System.Threading.Tasks.Extensions requires .NET Framework version 4.6 on NET 4.5.2 Web API projects RRS feed

  • Question

  • Hi there,

    I have a Web API that must run on .NET Framework version 4.5.2.

    When I install the nuget package System.Threading.Tasks.Extensions on the solution, the package introduces the runtime dependency of .NET Framework version 4.6

    As a side note, on a test console application the result is as expected. You install System.Threading.Tasks.Extensions and you can run the application on .NET 4.5.2

    Thursday, April 6, 2017 10:17 AM

All replies

  • Hi Jesús Corrius,

    Thank you for posting in MSDN forum.

    I try the following steps to reproduce it, the same result as yours:

    1. Create a Web API project which targets on the .Net Framework 4.5.2 .

    2. Install the  System.Threading.Tasks.Extensions from Nuget package manager.

    3. Although it shows the Platform which is available on the v4.6.1, but also works smoothly on the .Net Framework 4.5.2 without any error information.

    How about telling us if there is any error message on your side? or if I misunderstand your question, please explain more about it, I will try to help you solve it.

    Best Regards,


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Friday, April 7, 2017 8:09 AM
    Moderator