none
Installing VS2008 broke report previews in VS2005 RRS feed

  • Question

  • The title says it all, I now get an exception when I try to preview any report in VS 2005.  The error is displayed as an image so I'm not listing all 14 arguments and their types (it's 5 lines long)...

     

    ----------Begin error----------

    An error occurred during local report processing.  Method not found: 'Void Microsoft.ReportingServices.ReportProcessing.ReportProcessingContext..ctor()'

    ----------End error----------

     This happens for every report I've tried (dozens) that all used to work fine.  I even went and made up a report with no data and one static field and it still errors.  This report runs fine on the server of course.  Here's that RDL, in case it helps:

    <?xml version="1.0" encoding="utf-8"?>
    <Report xmlns="http://schemas.microsoft.com/sqlserver/reporting/2005/01/reportdefinition" xmlns:rd="http://schemas.microsoft.com/SQLServer/reporting/reportdesigner">
      <InteractiveHeight>11in</InteractiveHeight>
      <rd:DrawGrid>true</rd:DrawGrid>
      <InteractiveWidth>8.5in</InteractiveWidth>
      <rd:SnapToGrid>true</rd:SnapToGrid>
      <RightMargin>0.5in</RightMargin>
      <LeftMargin>0.5in</LeftMargin>
      <BottomMargin>0.5in</BottomMargin>
      <rd:ReportID>d3bdcaae-a929-41e4-812d-56ad59b8c4a0</rd:ReportID>
      <Width>7.5in</Width>
      <Body>
        <ReportItems>
          <Textbox Name="textbox1">
            <rd:DefaultName>textbox1</rd:DefaultName>
            <Style>
              <FontSize>24pt</FontSize>
              <TextAlign>Center</TextAlign>
            </Style>
            <CanGrow>true</CanGrow>
            <Height>0.375in</Height>
            <Value>This is a test</Value>
          </Textbox>
        </ReportItems>
        <Height>1in</Height>
      </Body>
      <Language>en-US</Language>
      <TopMargin>0.5in</TopMargin>
    </Report>


    Ken
    Friday, January 30, 2009 7:35 PM