locked
I am not able to connect with server using TLS 1.1 on windows 10. RRS feed

  • Question

  • I'm facing the issues on windows 10 to connect with the server using TLS 1.1 security protocol. My application is using https for client server communication. Is Windows 10 does not support TLS 1.1? Any help and suggestions would be appreciated. 


    Wednesday, February 21, 2018 5:43 AM

All replies

  • Making exceptional claim but asking other people to disapprove you means you don't have proof. You should not jump to conclusions like that. 

    Setup a virtual machine (so you can revert easily) with a clean install of Windows 10. Then install your program and see if it works. You should do this every time you plan to release an update to anyone else, even for internal testing. Running on a clean machine is the first test you should do to your installer. This also can help you find out problems caused by corrupt system files or incorrect settings on your devbox. Rebuild your devbox if your program works on everyone else's machine. 

    Also make sure the web site you are talking to is not down or blocking your IP address. That means you need to at least test the connectivity from another network location. If you don't have one, go rent a machine in the cloud.

    And you need to make sure the server has TLS 1.1 support during the lifecycle of your program, so you need to have good contact with the server administrator.  Or just add TLS 1.2 support (the web server should really be supporting it by now) and downgrade if TLS 1.2 is not available.



    Visual C++ MVP



    Thursday, March 1, 2018 1:39 PM