none
vs 2008 Win 7 change to computer question RRS feed

  • Question

  • I am using VS 2008 in Win 7, logged in as administrator, UAC turned on to default. Every time I start VS 2008, I get the question about allowing changes to the computer. I never get that question for recently installed VS 2010.

    Any ideas about how to get rid of this are welcome.

    Saturday, September 4, 2010 3:00 PM

Answers

  • Hello,

    You may try the following steps to see if they help:

    To resolve this issue:
    1. Run VS as administrator(Right-click the icon and choose 'Run as administrator').
    2. Try to run devenv /ResetSettings (in command prompt) to eliminate the related potential settings problem.
    3. Try disabling Add-ins (e.g. “Tools” | “Add-in Manager”) or run “devenv.exe /SafeMode”.This can eliminate the possibility that third party Add-ins or packages are causing problems. (For more detailed VS command line switches information, see: http://msdn2.microsoft.com/en-us/library/xee0c8y7.aspx )
    4. Try creating a new project. Sometimes corrupted project settings can cause problems. These are project specific.
    5. Make sure that we have the latest service pack applied. Apply VS2008 sp1.
    6. Try to reboot the operating system to safe mode. This can help to isolate whether any other applications are interfering with Visual Studio. Note that some features (like IIS) are not available under safe mode. Please check whether this can be applied or not. In addition to safe mode, we can also try “clean boot”: How to configure Windows XP to start in a "clean boot" state http://support.microsoft.com/kb/310353 .
    7. Try to create a new user account. This can help isolate user profile corruption related causes.

    Additionally, another useful tool is the Process Monitor tool http://www.microsoft.com/technet/sysinternals/utilities/processmonitor.mspx which can capture the access log.
    Filter on the process name devenv.exe in the log so that you see only the related list.
    This should give you more info on what are the registry keys/ files being accessed when the issue happens.


    Please remember to mark the replies as answers if they help and unmark them if they provide no help

    Wednesday, September 8, 2010 5:07 AM
    Moderator

All replies

  • Hello,

    You may try the following steps to see if they help:

    To resolve this issue:
    1. Run VS as administrator(Right-click the icon and choose 'Run as administrator').
    2. Try to run devenv /ResetSettings (in command prompt) to eliminate the related potential settings problem.
    3. Try disabling Add-ins (e.g. “Tools” | “Add-in Manager”) or run “devenv.exe /SafeMode”.This can eliminate the possibility that third party Add-ins or packages are causing problems. (For more detailed VS command line switches information, see: http://msdn2.microsoft.com/en-us/library/xee0c8y7.aspx )
    4. Try creating a new project. Sometimes corrupted project settings can cause problems. These are project specific.
    5. Make sure that we have the latest service pack applied. Apply VS2008 sp1.
    6. Try to reboot the operating system to safe mode. This can help to isolate whether any other applications are interfering with Visual Studio. Note that some features (like IIS) are not available under safe mode. Please check whether this can be applied or not. In addition to safe mode, we can also try “clean boot”: How to configure Windows XP to start in a "clean boot" state http://support.microsoft.com/kb/310353 .
    7. Try to create a new user account. This can help isolate user profile corruption related causes.

    Additionally, another useful tool is the Process Monitor tool http://www.microsoft.com/technet/sysinternals/utilities/processmonitor.mspx which can capture the access log.
    Filter on the process name devenv.exe in the log so that you see only the related list.
    This should give you more info on what are the registry keys/ files being accessed when the issue happens.


    Please remember to mark the replies as answers if they help and unmark them if they provide no help

    Wednesday, September 8, 2010 5:07 AM
    Moderator
  • Thanks for all the ideas. Have tried them and nothing helps.

    I suspect that it is in the interface between the UAC and VS 2008. Maybe moving the install location off the C: drive will do it...

    Wednesday, September 15, 2010 1:19 PM