none
Error APPX1204 when packaging a Windows Store app RRS feed

  • Question

  • I have developed a Windows Store app for Windows 8 (64 bits) in Visual Studio 2012 Ultimate version 11.0.60610.01 Update 3, written in C#, where Windows 8 is running on a VM hosted by means of Oracle VM Virtual Box Manager. The app can be compiled and tested on my development machine without any problem. In the properties of the project, tab Signing, I have checked the option that I want to sign with the generated temporary key which is part of the project. However, when I try to create a package for testing on another machine (Project -> Store -> Create App Packages -> No -> Create), after the project has been built and been compiled into an appx file, the creation process stops with the following error: 

    error APPX1204: Failed to sign '\\VBOXSVR\d_drive\Projecten\[CustomerName]\IncidentenBestrijding\src\IncidentenApp\AppPackages\IncidentenApp_0.0.0.1_x86_Test\IncidentenApp_0.0.0.1_x86.appx'. SignTool Error: An unexpected internal error has occurred.

    Incidentally, I get the same type of error when I create a brand new Windows Store project containing only a blank page.

    I have been trying to find clues for this problem on the internet. There are some references to this problem, suggesting that it might be caused by a lacking or invalid certificate. Therefore, I have tried a couple of solutions: 

    •         First, I have tried to renew my certificate (Package.appxmanifest -> Packaging -> Choose certificate -> Configure certificate -> Create test certificate).
    •         Then I have tried to produce my own certificate, based on the publisher name which is visible in the app manifest, tab Packaging:

    makecert -r -n "CN=CGI" -a sha1 -sv CGI.pvk –ss root

    makecert -a sha1 -sk "CGI" -iv CGI.pvk -n "CN=CGI" -ic CGI.cer -sr currentuser -ss My

    •         Then, I have tried to install the certificate wrapped in the temporary key (Package.appxmanifest -> Packaging -> Choose certificate -> View Full Certificate -> Install certificate -> Local machine -> Automatically select certificate store -> Finish).

    Neither of these approaches have helped to solve the problem. Maybe I should mention, however, that after the second approach I got a different error:

    error MSB3325: Cannot import the following key file: IncidentenApp_TemporaryKey.pfx. The key file may be password protected. To correct this, try to import the certificate again or manually install the certificate to the Strong Name CSP with the following key container name: VS_KEY_9816204FE52508B7

    After this new error I run the following code:

                   sn -i IncidentenApp_TemporaryKey.pfx VS_KEY_9816204FE52508B7

    but after that the original error returned. I am afraid that by now I feel a bit lost in the security swamp, and hope you can help me out. Many thanks in advance!

    Thursday, September 12, 2013 11:40 AM

All replies

  • This question has remained unanswered for more than 2 weeks now. I would appreciate if a Microsoft support employee would give his or her attention to it!
    Monday, September 30, 2013 8:24 AM