locked
Deploying Timetracker to a production server RRS feed

  • Question

  • User-418254652 posted

    Hi,

    I finally got my version of timetracker running fairly smooth and want to try and publish it to a production server.

    I deploy the app using the copy web site tool in VS express.  It copies over fine but I am getting errors.  I looked at the web.config file and noticed two setting

    <compilation debug="true"> ....I assume I change this to <compilation debug="false">

    the other setting

    <customErrors mode="RemoteOnly"/> i was going to change to this as well, but not sure what to change it to.

    Is there anything else I should do, be thinking about or read, in order  to deploy to production server?

    Any help would be appreciated

    Thanks,

     Mike

    Monday, May 7, 2007 12:07 PM

Answers

  • User-418254652 posted
    I changed the site to support ASP.NET 2.0 in IIS, it was set to 1.0.  Once I changed this it worked fine.  The site probably couldn't read the config file at all.  Now I'm getting errors related to my report viewer.
    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Monday, May 7, 2007 3:26 PM
  • User-418254652 posted
    I changed the site to support ASP.NET 2.0 in IIS, it was set to 1.0.  Once I changed this it worked fine.  [:)]  The site probably couldn't read the config file at all.  Now I'm getting errors related to my report viewer.
    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Monday, May 7, 2007 3:27 PM

All replies

  • User-1639143169 posted

    <compilation debug="false"> This is a must for production, unless you need to deploy, like you said you had errors, so you might want to leave as true, untill all errors are sorted.

     

    Monday, May 7, 2007 1:22 PM
  • User-1639143169 posted

    <compilation debug="false"> This is a must for production, unless you need to deploy, like you said you had errors, so you might want to leave as true, untill all errors are sorted.

    You may want to look into asp.net 2.0 precompilation options, and web deployment projects for precompiling, and defining deployment rules.

    [ http://weblogs.asp.net/scottgu/archive/2005/11/06/429723.aspx ]

    <customErrors mode="RemoteOnly"/>  -- Decides if you should dsiplay server errrors, or hide them allowing for a custom "polite" error page you design.

    Options are RemoteOnly, meaning if you are on the local server, you will get yellow screen messages, if you are a remote client you will get IIS style errors.

    <customErrors mode="Off"/> - Always show the real yellow screen errors

    Another thing you may want to think about is <Trace enabled="" /> On or Off, Off is more perfomrnace, trace lets you get information.

     

     

    Monday, May 7, 2007 1:25 PM
  • User-418254652 posted

    I don't have any errors when I run it from VS express.  Only when I use copy web site and move it to my Win 2003 server.  Then I get the error below.  I did add the <customErrors mode="Off"/>, but I still get the error.

    Runtime Error

    Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine.

    Details: To enable the details of this specific error message to be viewable on remote machines, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "Off".

    <!-- Web.Config Configuration File -->
    
    <configuration>
        <system.web>
            <customErrors mode="Off"/>
        </system.web>
    </configuration>

    Monday, May 7, 2007 1:29 PM
  • User-1639143169 posted

    Once you added customErrors off, what is the error you are getting?

    The problems could be any number of things.

    Can you post your entire web.config file, that you delpoyed to production?

    Monday, May 7, 2007 1:35 PM
  • User-418254652 posted
    I get the error listed in a reply above.  I get this no matter what changes I make to the web.config file.  I started and stopped the web site so the changes would persit through, but this didn't seem to help.  The site works fine when I run it from VS express.  It looks like it copies over.  I did make a simple ASP.NET app using notepad earlier and that worked.
    Monday, May 7, 2007 1:52 PM
  • User-418254652 posted

    Not sure what you mean by this......Can you post your entire web.config file, that you delpoyed to production?

    My web.comfig did get copied to IIS, it is under a website I created called "test1"  it worked earlier with another test app.  Some of the changes I made to web.config I made using Notepad and saved it back

    Monday, May 7, 2007 1:56 PM
  • User-1639143169 posted

    You have not posted any actual error. You posted the yellow screen requesting that you turn custom errors off to view the real error.

    I still have not seen the actual error message.

    You need to modify the web.config on production as stated above, to get a different message, something with an exception of some sort.

     

    Monday, May 7, 2007 1:59 PM
  • User-1639143169 posted

    I mean... can you copy paste your web.config and post it here. Feel free to block your connections strings and other security info. I just want to see the web.config to see if we can spot any issues there.

     

    Monday, May 7, 2007 2:00 PM
  • User-418254652 posted

     Below is my web.config.  I added the cutom error mode = "Off", but still get the same error (or lack of Error) page I pasted above.  This site started as the Timetracker starter kit.  All but a couple of entries (attributes) on the file was created by MS.

      

    <?xml version="1.0"?>
    <configuration xmlns="http://schemas.microsoft.com/.NetConfiguration/v2.0">
     <connectionStrings>
      <remove name="LocalSqlServer" />
      <add name="LocalSqlServer" connectionString="Data Source=.\SQLExpress;Integrated Security=True;AttachDBFilename=|DataDirectory|TimeTracker.mdf;User Instance=true" />
      <add name="aspnet_staterKits_TimeTracker" connectionString="Data Source=.\SQLExpress;Integrated Security=True;AttachDBFilename=|DataDirectory|TimeTracker.mdf;User Instance=true" />
      <add name="ConnectionString" connectionString="Data Source=.\SQLEXPRESS;AttachDbFilename=|DataDirectory|\TimeTracker.mdf;Integrated Security=True;User Instance=True"
       providerName="System.Data.SqlClient" />
     </connectionStrings>
     <system.web>

     


     <customErrors mode="Off"/>

     

      <httpHandlers>
       <add path="Reserved.ReportViewerWebControl.axd" verb="*" type="Microsoft.Reporting.WebForms.HttpHandler, Microsoft.ReportViewer.WebForms, Version=8.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a"
        validate="false" />
      </httpHandlers>
      <siteMap defaultProvider="AspNetXmlSiteMapProvider" enabled="true">
       <providers>
        <clear/>
        <add name="AspNetXmlSiteMapProvider" type="System.Web.XmlSiteMapProvider, System.Web, Version=2.0.3600.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" siteMapFile="web.sitemap" securityTrimmingEnabled="true"/>
       </providers>
      </siteMap>
      <authentication mode="Forms">
       <forms loginUrl="~/TimeTracker/login.aspx"/>
      </authentication>
      
    <compilation debug="false">
       <assemblies>
        <add assembly="Microsoft.ReportViewer.WebForms, Version=8.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A" />
        <add assembly="Microsoft.ReportViewer.Common, Version=8.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A" />
       </assemblies>
       <buildProviders>
        <add extension=".rdlc" type="Microsoft.Reporting.RdlBuildProvider, Microsoft.ReportViewer.Common, Version=8.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" />
       </buildProviders>
      </compilation>
      <customErrors mode="RemoteOnly"/>
      <machineKey decryptionKey="AutoGenerate,IsolateApps"/>
      <roleManager enabled="true"/>
     </system.web>
    </configuration>

    Monday, May 7, 2007 2:07 PM
  • User-1639143169 posted

    At the top of ytour web.config you have <customErrors mode="Off"/>

    At the bottom you still have <customErrors mode="RemoteOnly"/>
    Get rid of "<customErrors mode="RemoteOnly"/>"

    And leave only <customErrors mode="Off"/>

     Then lets see if we get a real error.

     Basically your second entry is overwritting the first one, so <customErrors mode="Off"/> is not actually taking effect.

    Monday, May 7, 2007 2:29 PM
  • User-418254652 posted

    I went into explorer and opened the web.config in notepad.  I deleted "<customErrors mode="RemoteOnly"/>", saved it

    stop and started the site, but still get the same error.  going to lunch

    Mike

    Monday, May 7, 2007 2:39 PM
  • User-418254652 posted
    I changed the site to support ASP.NET 2.0 in IIS, it was set to 1.0.  Once I changed this it worked fine.  The site probably couldn't read the config file at all.  Now I'm getting errors related to my report viewer.
    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Monday, May 7, 2007 3:26 PM
  • User-418254652 posted
    I changed the site to support ASP.NET 2.0 in IIS, it was set to 1.0.  Once I changed this it worked fine.  [:)]  The site probably couldn't read the config file at all.  Now I'm getting errors related to my report viewer.
    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Monday, May 7, 2007 3:27 PM
  • User555306248 posted
    Thats nice [:)]
    Monday, May 7, 2007 11:07 PM