none
SSL support in TP5 with WindowsServerCore images? RRS feed

  • Question

  • Is this available yet? If so how to enable and get it working?

    I still am facing the issue of Container Host restart when I do "wget https://localhost" from within a powershell session in container with IIS enabled with https binding.

    Thanks,

    Rasheed

    Friday, May 20, 2016 1:25 PM

Answers

  • Hi Rasheed,

    We have a workaround for this included with the IIS-HTTPS sample here:

    https://github.com/Microsoft/Virtualization-Documentation/tree/master/windows-container-samples/windowsservercore/iis-https

    Can you give it a try and let us know if it works for you?

    Thanks!
    Patrick

    Monday, May 23, 2016 6:46 PM

All replies

  • Hi Rasheed,

    We have a workaround for this included with the IIS-HTTPS sample here:

    https://github.com/Microsoft/Virtualization-Documentation/tree/master/windows-container-samples/windowsservercore/iis-https

    Can you give it a try and let us know if it works for you?

    Thanks!
    Patrick

    Monday, May 23, 2016 6:46 PM
  • Hi Patrick,

    Thanks!

    The work around steps did help create a  port map of 443 in container to a random port in container host. But it still does not allow me to create a port map 443 on container to 443 on container host. It throws the below error when I start the container.

    docker: Error response from daemon: failed to create endpoint jolly_bose on network nat: HNS failed with error : Failed to create endpoint.

    Due to the intricacies of my application I must port map to 443 itself. I have made sure no other apps are listening in on port 443 on container host.

    Please let me know at the earliest,

    Thanks,

    Rasheed

    Tuesday, May 24, 2016 3:33 PM
  • I'm guessing you have something else listening on port 443 on your host, you may need to find it and stop/disable it.
    Thursday, June 16, 2016 11:37 AM