none
Has there been any success running the SDK 2.0 and Kinect 2v on Windows Server 2012 R2 RRS feed

  • Question

  • I know the documentation says it suppose windows 8 and their embedded devices, but I want to see if I can develop on my windows 2012 r2 test machine. I have been able to install the SDK, and my device manager detects the sensor, but I am having trouble displaying video in the Kinect Studio. I am looking for any workarounds.

    I also have hyper v activated, is this an issue?

    Thanks!


    this is my signature

    Thursday, July 17, 2014 3:07 PM

Answers

All replies

  • Server is not a supported sku. Hyper-V is known to interfere with the GPU operations even on desktop. What is the GPU you have on the server? Is it DX11 capable?

    Carmine Sirignano - MSFT

    Thursday, July 17, 2014 6:31 PM
  • The following is a the description from of my GPU from the DirectX Diagnostic. I believe I am using a dedicated video card as opposed to a integrated video card. I am also using usb 3.0 card as well. I am unsure if the issue lies with the video card, usb 3.0, or the actual windows server 2012 r2. I posted this question to rule out the latter.

    Thanks, again,

    Sammy


    this is my signature

    Thursday, July 17, 2014 8:23 PM
  • It is not a DX11 based GPU. On your first screenshot, the feature level is 10.0, 9.3, 9.2, 9.1 only, so it will not work.

    Carmine Sirignano - MSFT

    Thursday, July 17, 2014 9:30 PM
  • Thanks, Carmine!

    this is my signature

    Friday, July 18, 2014 6:10 AM
  • Hi, I am trying to get my Kinect for Windows v2 running on a Windows Server 2012R2 and my feature levels do include 11.0 (as well as 10.1, 10.0, 9.3, 9.2, 9.1), Driver Model WDDM 1.3, and DirectX v. 11. 

    I am using AMD FirePro V4900 (FireGL V) with 33.5 GB total memory.

    The Kinect is plugged into a USB 3.0 with a Renesas controller (and no other devices on the 3.0 hub) and it is not working.    Can you please help?

    ---Andrew

    Tuesday, July 29, 2014 9:12 PM
  • I was successful in running Kinect for Windows 2 on a Windows Server 2012R2 box. I had to use a different box from my previous question because the 3.0 USB port was an extension or card add-on. The new box had the 3.0 port connected to the motherboard, and I had a compatible video card. I installed the "Windows Desktop Experience Feature", and I made sure Hyper-V was not installed. That is was my set up.

    After installing the SDK, does the machine recognize that there is a NUI sensor connected? And when you try running, are you getting a error message that the USB is not able to handle the resources?


    this is my signature


    Wednesday, July 30, 2014 7:27 PM
  • The box came configured with Hyper-V installed, but I will try shutting down the services relating to Hyper-V and see if that works.

    Windows recognizes the sensor but in the Device Manager it indicates there is a problem (0xA).

    ---Andrew

    Wednesday, July 30, 2014 7:57 PM