none
How to accept trademark symbol ® in to the data element RRS feed

  • Question

  • I am receiving a EDI 810 file from the vendor which has trade mark symbol ®. Is there a way in BizTalk to accept this character?

    The EDI data I am receiving as:

    H.BIG: BIG*20090630*446455*20090625*4500007656***DI
    H.N1.N1: N1*RE*Vendor
    H.N1.N1: N1*ST*Ship to name
    H.N1.N3: N3*Add1
    H.N1.N4: N4*City*ST*12345*US
    H.ITD: ITD*01*3****20090829
    B.IT1.IT1: IT1*1*1*EA*175.5**VN*285532
    B.IT1.PID.PID: PID*F****Microsoft®
    T.TDS: TDS*18789
    T.SAC.SAC: SAC*C*D240***1239
    T.CTT: CTT*1

    And BizTalk generated this error :

    Event Type: Error
    Event Source: BizTalk Server 2006 EDI
    Event Category: None
    Event ID: 8114
    Date:  7/9/2009
    Time:  10:40:21 AM
    User:  N/A
    Computer: BIZDEV
    Description:
    Error encountered during parsing. The X12 transaction set with id '0001' contained in functional group with id '1732', in interchange with id '000001732', with sender id 'Vendor      ', receiver id 'Company         ' is being suspended with following errors:

    Error: 1 (Field level error)
     SegmentID: PID
     Position in TS: 9
     Data Element ID: PID05
     Position in Segment: 5
     Data Value:
     6: Invalid character in data element


    I know ® is not part of Basic or Extended character set like it is explained here
    http://msdn.microsoft.com/en-us/library/bb246115.aspx.


    I also tried to change the Basic data type property from X12_AN to string to bypass the X12_AN validation. It did not work.

    I want know if any one succeeded with that effort or is there a way to define a custom data types in the EDI schemas which accepts characters other than Basic and Extended?

    Thank you
    Ram


    The Developer
    Thursday, July 9, 2009 4:16 PM

Answers

  • Did it not work using the UTF-8 character set?
    You might have to have a decode component that replaces ® with \R, and then on your output replace \R with ®.



    Eric Stott [http://blog.biztalk-info.com] - Mark as Answer if this reply does.
    Thursday, July 9, 2009 5:18 PM
  • Hi Ram,

    ® doesn’t come under Basic or Extended Character set so put UTF8 in the pipeline setting and the input file has to be in UTF8 encoding.


    Kowshik Palivela
    Friday, July 10, 2009 5:31 AM
  • Eric & Kowshik

    In theory UTF8 encoding supposed to work with Unicode character set. But looks like it is not working. I enabled UTF8 both on Party’s EDI Property and Receive pipeline.

     

    Any way I solved this problem by using custom component for now.

     

    But I think if BizTalk Dev team can provide options to include some special characters to be accepted in EDI docs would be a good idea. I know these characters may be not a valid characters in terms of X12 standards but it is not easy to explain to customers. Especially trademark symbols.

    Thanks for your help guys.


    The Developer
    Friday, July 10, 2009 2:56 PM
  • You need to also save the file in Unicode format. Specifying the UTF-8 in pipeline component alone won't solve the problem.
    Bhola Meena [http://blogs.msdn.com/biztalkb2b]
    Friday, July 10, 2009 4:59 PM

All replies

  • Did it not work using the UTF-8 character set?
    You might have to have a decode component that replaces ® with \R, and then on your output replace \R with ®.



    Eric Stott [http://blog.biztalk-info.com] - Mark as Answer if this reply does.
    Thursday, July 9, 2009 5:18 PM
  • Hi Ram,

    ® doesn’t come under Basic or Extended Character set so put UTF8 in the pipeline setting and the input file has to be in UTF8 encoding.


    Kowshik Palivela
    Friday, July 10, 2009 5:31 AM
  • Ram,

    Before you do a lot of work, make sure that your trading partner will accept the character in the transaction!


    Jim -- Pro Mapping in BizTalk 2009, Apress Books, March 23, 2009
    Friday, July 10, 2009 2:43 PM
  • Eric & Kowshik

    In theory UTF8 encoding supposed to work with Unicode character set. But looks like it is not working. I enabled UTF8 both on Party’s EDI Property and Receive pipeline.

     

    Any way I solved this problem by using custom component for now.

     

    But I think if BizTalk Dev team can provide options to include some special characters to be accepted in EDI docs would be a good idea. I know these characters may be not a valid characters in terms of X12 standards but it is not easy to explain to customers. Especially trademark symbols.

    Thanks for your help guys.


    The Developer
    Friday, July 10, 2009 2:56 PM
  • Should I change this

    <?xml version="1.0" encoding="utf-16" ?>

    If so how? I thought I changed it to "utf-8" in the Code view but it is keep showing as utf-16. I even tried to edit that part with notepad.

    Thanks
    Ram

    The Developer
    Friday, July 10, 2009 3:38 PM
  • You need to also save the file in Unicode format. Specifying the UTF-8 in pipeline component alone won't solve the problem.
    Bhola Meena [http://blogs.msdn.com/biztalkb2b]
    Friday, July 10, 2009 4:59 PM