Remove AD integration RRS feed

  • Question

  • We have SQL 2000 on a Windows 2003 server that used to be in a domain. I removed the computer from the domain and made it part of it's own workgroup, and I changed the services to start with a local account. It seems that SQL is still trying to register itself with the non-existent domain, because I see the MSSQLServerADHelper service, and I am getting "SuperSocket info: (SpnRegister) : Error 1355." error messages. Is there some way for me to stop SQL from trying to register itself in AD? I've tried "exec sp_ActiveDirectory_SCP @action=N'delete'" but I get the message "Active Directory is either not enabled on the network or not supported by the operating system.".

    Thank you.
    Thursday, August 27, 2009 2:31 PM


  • This is there all the time, even if you were never in a domain in the first place. I think they improved it in 2005 (remove error).
    Tibor Karaszi, SQL Server MVP http://www.karaszi.com/sqlserver/default.asp http://sqlblog.com/blogs/tibor_karaszi
    Thursday, August 27, 2009 8:07 PM