none
The formula contains reference(s) to field(s). RRS feed

  • Question

  • I recently was given the task of trying to clean up our companies sharepoint site. It is WSS 2.0 but we are going to migrate to 3.0 once we figure out exactly how we want to do that. The person that set our system up didn't really understand sharepoint so it has no structure to speak of. Anyway, our clinic has a site that they use for appointments, billing tracking and a few others. at this time there is a column that is labeled Date Trans. that when filled out, will automatically transfer the file to the next page called Permanent view. They want to be able to take the information from the Date Trans. column and compare it to the Appt. Date date column and if the Appt. Date is before the Date Trans. column it won't transfer the appointment. I have tried the formula =IF([Appt. Date]>[Date Trans.],"ok", "not OK") but I get "The formula contains reference(s) to field(s)." I'm sure there is an easy fix for this but since I am new to this I can't see it. Any help will be appreciated.

    Mark
    Thursday, September 4, 2008 8:17 PM

Answers

  • Hi,

    I think you should create a new calculated column and set it’s formula as “=IF([Appt. Date]>[Date Trans.],"ok", "not OK")”.

    Go to Settings>Create column>select “Calculated (calculation based on other columns)” > In Formula text box input “=IF([Appt. Date]>[Date Trans.],"ok", "not OK")”.

    Hope it helps.


    Xue-Mei Chang
    Monday, September 8, 2008 9:46 AM
    Moderator

All replies

  • Try this formula:

    =IF(DATEDIF(Appt Date,Date Trans,"D")>1,"ok","not ok")

    I hope this should work....if not just manipulate the formula little bit & it will work.

    Thanks, Arpit
    Thursday, September 4, 2008 9:10 PM
  • I tried that and it came back with the same error. When adding this formula to wss2.0 I'm assuming that I would go to the edit column page and input the formula in the calculated value box on the date trans. page???

    Friday, September 5, 2008 5:47 PM
  • Hi,

    I think you should create a new calculated column and set it’s formula as “=IF([Appt. Date]>[Date Trans.],"ok", "not OK")”.

    Go to Settings>Create column>select “Calculated (calculation based on other columns)” > In Formula text box input “=IF([Appt. Date]>[Date Trans.],"ok", "not OK")”.

    Hope it helps.


    Xue-Mei Chang
    Monday, September 8, 2008 9:46 AM
    Moderator