none
Biztalk 2010 publish Stored Procedueres as WCF Service, but some methods don't work RRS feed

  • General discussion

  • Hi All,  This is Jessie,

    I published SQL stored procedures as wcf services. Before published them, I have tested every stored procedure, they all worked.

    After the service been published, I have tested every single method in the WCF service in SoapUI, all worked.

    Then I add the wcf service as reference into the Visual Studio project (C# Code). One of the method -- 'GetClient' is based on ClientID and ClientName those 2 parameters to get  ClientID, ClientName,ClientPhone, ClientEmail, ClientAddress.

    When starting to debug the project, code calls "GetClient", it always has an error says the stored procedure or function 'GetClient' expects @ClientID, which was not supplied.  the code looks pass the ClientID and ClientName in, for some reason which I dont know, the biztalk doesn't recognize or doesn't take ClientID as a parameter. 

    Is there anything wrong in the orchestration design? or any places? please give me a clue..

    Appreciate your all help!! Thank you!!

    Tuesday, December 6, 2011 8:02 PM

All replies

  • Your question is a little confusing. Did you generate a schema for the SQL stored procedure and then published the schema as a WCF service?

    What part of your solution includes the orchestration? Could you describe the orchestration?

    Thanks,


    If this answers your question, please use the "Answer" button to say so | Ben Cline
    Friday, December 9, 2011 4:29 AM
    Moderator