none
Autodiscover request from computer not in domain RRS feed

  • Question

  • Hi everybody,

    I am sending autodiscover request from a computer not in domain. Can somebody help me how to do this? Autodiscover request is successful when sent from a computer which is in domain. I have mixed environment of one Exchange Server 2007, one Exchange Server 2010 and two Exchange Server 2013. Kindly help me in this matter.

    Thanks & regards,

    Amit Jha

    Wednesday, April 15, 2015 1:21 PM

Answers

All replies

  • Hi Amit Jha,

    You probably need to design a separate autodiscover for your Mixed environment, this because you need to concentrate the traffic. Otherwise, you need to verify your Firewall rules for autodiscover.

    There is an article from technet to help you on this problems:

    https://technet.microsoft.com/en-us/library/aa995928(v=exchg.141).aspx

    Best Regards!

    Ewerton Manzotte


    sempretom

    Wednesday, April 15, 2015 1:42 PM
  • I'm going to assume that you already put Exchange 2013 in the head of everything in terms of client access.  Since the workstation is not on the domain, Outlook can't do SCP lookups for autodiscover.  This means it's going to fail back to searching preprogrammed well known addresses for autodiscover (ex. autodiscover.domain.com, www.domain.com/autodiscover, etc). So if you make sure the workstation can properly resolve autodiscover.domain.com to an Exchange CAS Server (I would have it resolve to a load balancer that fronts my Exchange 2013 CAS Servers and let 2013 figure out autodiscover) and that the appropriate ports are available to the workstation you shouldn't have any issues (other than some password prompts, but that should be expected since the machine is not a domain joined workstation). 

    Oh, one more thing, since this is not on the domain, I'm 99% sure that autodiscover is going to return the ExternalURL values for services, (outlook anywhere, EWS, OAB, ect.) you should make sure those resolve appropriately as well. 


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread

    Wednesday, April 15, 2015 2:10 PM
  • Hi Ewerton,

    Its working OK in mixed environment. Concentrate on the question asked. I am having difficulty in sending autodiscover request from a computer not in domain. Do you know how to do it?

    Thursday, April 16, 2015 9:41 AM
  • Hi Hinte,

    You wrote: "Since the workstation is not on the domain, Outlook can't do SCP lookups for autodiscover." Its application, not Outlook and I have used code in https://msdn.microsoft.com/EN-US/library/office/dn467395(v=exchg.150).aspx#bk_CodeExample and modified it according to my requirements. It does SCP look ups and works fine.

    I want to query EWS URL only using autodiscover from a computer not in domain. The result I am getting by the link mentioned in this reply all the EWS URLs.

    Thursday, April 16, 2015 9:57 AM
  • Hi everyone,

    I got the answer from How to: Find Autodisover endpoints by using SCP lookup in Exchange.

    Thanks for your time and help.



    Tuesday, May 26, 2015 6:29 AM