none
Power Pivot 2013 Issue ";" and "," RRS feed

  • Question

  • Hi,

    I am having some problems with power pivot for excel 2013 64bit,

    when typing a formula with two arguments the autocomplete doesn't work after typing the ";". However  if a type a ","  the autocomplete works but the formula doesn't work due to incorrect syntaxes.

    for example LastYearSales:=calculate(sum(Comercial[Data]);comercial[account]="Venta std") 

    If anyone knows how to solve this problem please let me know.

    Thank you in advance,


    Monday, January 26, 2015 3:52 PM

Answers

  • In addition to Olaf's suggestion you might want to double-check your Region and Language Control Panel settings. 

    Specifically, be sure that your List separator (found by pressing the [Additional settings...] button) is a comma and not a semi-colon.


    Monday, January 26, 2015 7:31 PM
  • Hello,

    I know this issue when the languages between OS/Excel/PowerPivot mismatch, looks like this

    Changing the language in Power Pivot settings solves the problem =>


    Olaf Helper

    [ Blog] [ Xing] [ MVP]

    • Proposed as answer by Charlie LiaoModerator Tuesday, January 27, 2015 7:21 AM
    • Marked as answer by alexthar Tuesday, January 27, 2015 9:51 AM
    • Unmarked as answer by alexthar Tuesday, January 27, 2015 11:01 AM
    • Marked as answer by alexthar Tuesday, January 27, 2015 11:12 AM
    Monday, January 26, 2015 5:15 PM
    Moderator
  • Indeed the solution in my case was just to change the Region and Language Control Panel settings as Mark suggested,"the List separator (found by pressing the [Additional settings...] button) is a comma and not a semi-colon" but  i found also that the decimal separator must be "."

    I suppose that will get fixed with the next update so I'll have to change settings again.

    Thank you


    • Marked as answer by alexthar Tuesday, January 27, 2015 11:10 AM
    • Edited by alexthar Tuesday, January 27, 2015 11:14 AM
    Tuesday, January 27, 2015 11:10 AM

All replies

  • this new "feature" came with one of the last O365 updates

    there was a similar thread some weeks ago, though, i cannot find it right now

    I am afraid we have to wait for the next O365 and hope it is fixed there :(

    -gerhard


    Gerhard Brueckl
    blogging @ http://blog.gbrueckl.at
    working @ http://www.pmOne.com

    Monday, January 26, 2015 5:01 PM
    Answerer
  • Hello,

    I know this issue when the languages between OS/Excel/PowerPivot mismatch, looks like this

    Changing the language in Power Pivot settings solves the problem =>


    Olaf Helper

    [ Blog] [ Xing] [ MVP]

    • Proposed as answer by Charlie LiaoModerator Tuesday, January 27, 2015 7:21 AM
    • Marked as answer by alexthar Tuesday, January 27, 2015 9:51 AM
    • Unmarked as answer by alexthar Tuesday, January 27, 2015 11:01 AM
    • Marked as answer by alexthar Tuesday, January 27, 2015 11:12 AM
    Monday, January 26, 2015 5:15 PM
    Moderator
  • In addition to Olaf's suggestion you might want to double-check your Region and Language Control Panel settings. 

    Specifically, be sure that your List separator (found by pressing the [Additional settings...] button) is a comma and not a semi-colon.


    Monday, January 26, 2015 7:31 PM
  • Thank you, it works!!
    • Marked as answer by alexthar Tuesday, January 27, 2015 9:51 AM
    • Unmarked as answer by alexthar Tuesday, January 27, 2015 9:51 AM
    Tuesday, January 27, 2015 9:51 AM
  • Indeed the solution in my case was just to change the Region and Language Control Panel settings as Mark suggested,"the List separator (found by pressing the [Additional settings...] button) is a comma and not a semi-colon" but  i found also that the decimal separator must be "."

    I suppose that will get fixed with the next update so I'll have to change settings again.

    Thank you


    • Marked as answer by alexthar Tuesday, January 27, 2015 11:10 AM
    • Edited by alexthar Tuesday, January 27, 2015 11:14 AM
    Tuesday, January 27, 2015 11:10 AM