none
Configuration Database issue while Deployment.

    Question

  • Hi,

    I have a BizTalk 2010 project which I want to deploy on a remote server. When I go to Properties-> Deployment -> Server and enter the Server name as 'RemoteServer'. I see an error in the Configuration Database: <No BizTalk Configuration database(s) found on server 'RemoteServer'.> and when I try to deploy I get error: Parameter name: strDBName

    However, when I open other projects, they already have Server 'RemoteServer' selected and Configuration database as 'BizTalkMgmtDb'. Also, I can successfully deploy these projects to the 'RemoteServer'. So, why in this project I'm not getting any Configuration database?

    Please help.

    Thanks.


    Kunal G

    Thursday, April 4, 2013 11:35 AM

Answers

  • Hi Kunal,

    I did some more work on this.

    Case 4:

    In Visual Studio’s “Deployment" panes --> Server, if I select any server where I don't have Login permission, then I get the Login error as you have mentioned:

    "Login failed for user 'domainNameAprabhu'."

    Resolution to Case 3:

    In case 4,  what I also noticed is when I update the existing Server name (server name where my BizTalkMgmtDb exist) in the Deployment pane, the drop down box unable to recognize the new SQL server (or not able to refresh the Databasename when any change happen to the Server name) failed with the error:

    <No BizTalk Configuration database(s) found on server 'SQL Serer Name'>

    However, if I start a new project from scratch, the application can easily find BizTalkMgmtDb.

    Then I logged into the database server where the BizTalkMgmtDb exist --> Security --> Logins --> Selected the group where my login (login to the machine where I have SQL Server, if database in the same machine as Visual studio then you can do this in the same server) --> Properties --> Server Roles --> Check "sysadmin" access.

    Then I came back to my Visual Studio, closed and restarted the Visual Studio, went to the Deployment pane in the Server property, I can now get the BizTalkMgmtDb without any issue. It’s a guaranteed privilege issue.

    Regards,

    M.R.ASHWINPRABHU


    If this answers your question please mark it accordingly. If this post is helpful, please vote as helpful.


    Friday, April 5, 2013 11:51 AM

All replies

  • Check Visual studio is opened as administrator.

    Regards

    Mohit Gupta

    Thursday, April 4, 2013 11:49 AM
  • Yes, it is.

    Kunal G

    Thursday, April 4, 2013 11:58 AM
  • Hi Kunal,

    Can you do couple of things:

    Reconfigure the deployment server in Visual Studio again. i.e. Close the Visual studio, Open it as administrator (again, if you have done)--> Right click BizTalk project -->Properties --> Deployment--> Type the server name again and select the BizTalkMgmtDb.

     

    Test the connection using the Server explore.

    In your Visual Studio goto View menu --> Server Explore --> Right click on Data Connection --> Select Add connection--> Select "Microsoft SQL Server" as Data soruce--> Give your SQL server name where BizTalkMgmtDb exists --> Select your BizTalkMgmtDb (even when you able to select the database means who could connect to your SQL Server) --> Click Test Connection

     


    If this answers your question please mark it accordingly. If this post is helpful, please vote as helpful.

    Thursday, April 4, 2013 12:17 PM
  • After selecting Server, I'm unable to write anything in Configuration Database option. It displays a message but I can't edit it.

    Though I'm able to test the Server Explorer Part successfully. 


    Kunal G

    Thursday, April 4, 2013 12:40 PM
  • Hi Kunal,

    Then this confirm the issue is with user access not with the connection/network issue. Can you add BizTalk admin group in the SQL server where BizTalkMgmtDb exists.


    If this answers your question please mark it accordingly. If this post is helpful, please vote as helpful.

    Thursday, April 4, 2013 12:53 PM
  • I don't have access to that.

    I have a doubt that if the user doesn't have access then how does it work in other projects with the same user ( as I'm able to deploy other projects.)

    Just to add, The projects that I can deploy are only those in which Server and Configuration DB are already selected. If the same setting is not selected in any other project, I can't make change in that also.


    Kunal G



    • Edited by Kunal G Thursday, April 4, 2013 1:04 PM
    Thursday, April 4, 2013 12:58 PM
  • Visual studio cannot not block the same user which it does allowed in other projects. Unless you have given a different SQL server details, not opened it as administrator or something has changed now which should block the user to deploy other projects as well now.


    If this answers your question please mark it accordingly. If this post is helpful, please vote as helpful.


    Thursday, April 4, 2013 1:05 PM
  • And you are positive that no extra space etc. has been pre- or appended to the Server name on this project, so that it somehow differs from the projects where it works?

    Morten la Cour

    Thursday, April 4, 2013 1:06 PM
  • Yes, I'm sure about that. 

    Just to add, The projects that I can deploy are only those in which Server and Configuration DB are already selected. If the same setting is not selected in any other project, I can't make change in that also.


    Kunal G

    Thursday, April 4, 2013 1:48 PM
  • Then this confirm the issue is with user access not with the connection/network issue.  

    One more thing I have noticed that if I type a Server to which I don't have access, it shows error in Configuration Database as Login failed for user 'Username'. Any comments on that?

    Kunal G

    Friday, April 5, 2013 6:39 AM
  • Hi Kunal G,

    I have replicated your issue.

    Case 1: In Visual Studio I have opened an existing BizTalk projects as a non-administrator, then I don’t see any error in the Deployment pane of the project. But when I deploy the project, I got “Access is Denied” error.

    Case 2: If I update the existing BizTalk project’s Deployment server name or if I create a new BizTalk project and change the deployment server to non existing SQL server, then I get the following error:

    A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server)

    Case 3:  In Visual studio, if I edit the deployment server name to an existing BizTalk server (edited it to get it refreshed and when I select “Database”) with an non-administrator access, then I get the your/following error:

    “No BizTalk Configuration database(s) found on server 'SQL Serer Name'.”

    Regards,

    M.R.ASHWINPRABHU


    If this answers your question please mark it accordingly. If this post is helpful, please vote as helpful.


    Friday, April 5, 2013 9:27 AM
  • Thanks. Mine is Case 3.

    Also, I know there is configuration DB on that Server, but still unable to connect.


    Kunal G

    Friday, April 5, 2013 10:19 AM
  • Hi Kunal,

    I did some more work on this.

    Case 4:

    In Visual Studio’s “Deployment" panes --> Server, if I select any server where I don't have Login permission, then I get the Login error as you have mentioned:

    "Login failed for user 'domainNameAprabhu'."

    Resolution to Case 3:

    In case 4,  what I also noticed is when I update the existing Server name (server name where my BizTalkMgmtDb exist) in the Deployment pane, the drop down box unable to recognize the new SQL server (or not able to refresh the Databasename when any change happen to the Server name) failed with the error:

    <No BizTalk Configuration database(s) found on server 'SQL Serer Name'>

    However, if I start a new project from scratch, the application can easily find BizTalkMgmtDb.

    Then I logged into the database server where the BizTalkMgmtDb exist --> Security --> Logins --> Selected the group where my login (login to the machine where I have SQL Server, if database in the same machine as Visual studio then you can do this in the same server) --> Properties --> Server Roles --> Check "sysadmin" access.

    Then I came back to my Visual Studio, closed and restarted the Visual Studio, went to the Deployment pane in the Server property, I can now get the BizTalkMgmtDb without any issue. It’s a guaranteed privilege issue.

    Regards,

    M.R.ASHWINPRABHU


    If this answers your question please mark it accordingly. If this post is helpful, please vote as helpful.


    Friday, April 5, 2013 11:51 AM
  • Hi Kunal,

    I am also facing the same issue. were you able to resolve the issue. please let me know the solution.

    Regards,

    swetha

    Monday, April 6, 2015 10:54 AM