locked
LinkId=26320 not found (Windows CE Emulator) RRS feed

  • Question

  • I am trying to use Microsoft's eMbedded Visual C++ 4.0 on WinXP SP2 and it is giving me a driver conflict error.

    The error I get says:

    Virtual PC/Windows CE Emulator:
    "A driver is installed that causes stability problems with your system. This driver will be disabled. Please contact the driver manufacturer for an update that is compatible with this version of Windows."

    The message also displays a Contact Information link:

    Web Site: http://go.microsoft.com/fwlink/?LinkId=26320

    But the link is no longer available.

    A phone number is also listed (to Microsoft) but I can not get an answer since I am not an MSDN subscriber.

    Some research into this problem has infomed me that Microsoft and Sun have settled some legal issues between them, the result of which is that Microsoft no longer supports the driver.

    • Does anyone know how to fix the driver?
    • What are the steps I need to resolve this problem?

    I can not debug my eMbedded Visual C++ 4.0 Applications until I can get this conflict resolved.

    Tuesday, August 1, 2006 8:32 PM

Answers

  • There is no way of fixing the driver itself.
    The following KB article provides the required steps to resolve the problem:
    http://support.microsoft.com/kb/891667/en-us

    Wednesday, August 2, 2006 6:47 AM
  • Brendan,

    The old newsgroup post said to remove the /pae and /noexecute options from my boot.ini settings.  The /pae option was not set, so all I did was to remove the /noexecute option.  I rebooted, but I still got the error.

    Later, I saw Michael's reply with a link to another set of instructions.  They were as follows:

    To resolve this problem and to run Window CE 4.x Emulator, disable hardware-based DEP on your computer that is running Windows XP SP2. To do this, follow these steps:

    1. Click Start, click Run, type sysdm.cpl, and then click OK. 
    2. In the System Properties dialog box, click the Advanced tab. 
    3. Under Start and Recovery, click Settings. 
    4. In the Startup and Recovery dialog box, click Edit. 
    5. Disable PAE mode by removing the /pae option if it exists. 
    6. Remove the /noexecute option if it exists. 
    7. Add the /execute option. 
    8. On the File menu, click Save. 
    9. To exit Notepad, click Exit on the File menu. 
    10. To close System Properties, click OK two times. 
    11. Restart your computer.

    Apparently, adding the /execute option was the key.  I restarted Windows, and I have not seen the problem.

    Thanks to you both.

    Wednesday, August 2, 2006 2:47 PM

All replies

  • Well that’s kind of rotten that the KB article is MIA as well as a couple of other links about the subject.

    From the sounds of it this is an XP SP2 related issue and you need to remove the /pae and /noexecute flags from your boot.ini file. Before getting into how to I must warn you that editing your boot.ini improperly can render your system unable to boot normally.

    Now then, the how to... take a look at the steps provided on this old newsgroup post.

    Tuesday, August 1, 2006 9:01 PM
  • There is no way of fixing the driver itself.
    The following KB article provides the required steps to resolve the problem:
    http://support.microsoft.com/kb/891667/en-us

    Wednesday, August 2, 2006 6:47 AM
  • Brendan,

    The old newsgroup post said to remove the /pae and /noexecute options from my boot.ini settings.  The /pae option was not set, so all I did was to remove the /noexecute option.  I rebooted, but I still got the error.

    Later, I saw Michael's reply with a link to another set of instructions.  They were as follows:

    To resolve this problem and to run Window CE 4.x Emulator, disable hardware-based DEP on your computer that is running Windows XP SP2. To do this, follow these steps:

    1. Click Start, click Run, type sysdm.cpl, and then click OK. 
    2. In the System Properties dialog box, click the Advanced tab. 
    3. Under Start and Recovery, click Settings. 
    4. In the Startup and Recovery dialog box, click Edit. 
    5. Disable PAE mode by removing the /pae option if it exists. 
    6. Remove the /noexecute option if it exists. 
    7. Add the /execute option. 
    8. On the File menu, click Save. 
    9. To exit Notepad, click Exit on the File menu. 
    10. To close System Properties, click OK two times. 
    11. Restart your computer.

    Apparently, adding the /execute option was the key.  I restarted Windows, and I have not seen the problem.

    Thanks to you both.

    Wednesday, August 2, 2006 2:47 PM