none
Stored Procedure Issue with BizTalk 2016 and DB2 Adapter RRS feed

  • Question

  • We have a BizTalk 2016 dev. VM and are trying to check the working of DB2 adapter. There is an external system from which BizTalk 2016 is trying to read records using a stored procedure, its definition below:

    CREATE PROCEDURE Procedure_Name (INOUT Variable_Name INTEGER)

    The issue we are facing in BizTalk 2016 is the StoredProcedure is returning the Output Parameter to BizTalk along with the result sets. This Output Param field has not been created in the schema. Even the adapter generated schema using the DB2 configuration does not contain this param as a field [https://docs.microsoft.com/en-us/host-integration-server/core/biztalk-adapter-for-db2-configuration1#create-a-db2-adapter-schema]

    This worked in BizTalk 2010, where on calling the Stored Procedure, BizTalk only received the result set without the output parameter, however in BT 2016, we are receiving the output param as well along with the result set. Is there a configuration to exclude the output param and only receive the result set?
    Thursday, July 12, 2018 3:41 PM

All replies

  • is this same setup with the same stored procedure worked in 2010 and just behaving differently in 2016 ?
    Thursday, July 12, 2018 3:56 PM
  • Hello, thanks for replying.

    Yes, same setup and same stored procedure worked in 2010 but behaving differently in 2016

    Please advise if any configuration needs to be done to exclude the output param and only receive the result set.

    Thursday, July 12, 2018 4:10 PM
  • INOUT param supposes to return output parameter; not sure how it was working another way in 2010. 

    Anyways, have you tried just making the input parameter of type IN just to test how it works?


    Friday, July 13, 2018 12:48 AM
  • Hello, thanks again for replying.

    Making parameter of only type IN is the last option since 6 stored procedures will need modification in the external system.

    Until then we are trying to check if any configuration needs to be done to exclude the output param and only receive the result set.

    Hi All,

    If you have come across this issue, please let us know asap. Thanks in advance.

    Friday, July 13, 2018 10:08 AM
  • Not the nicest but create a wrapper with only IN parameter for your current SP

    /Peter

    Friday, July 13, 2018 3:27 PM
  • Thank you Peter for the response.

    We will check on this option.

    Friday, July 13, 2018 4:38 PM