none
SQL Server in other computer

    Question

  • i have created a windows application in c# with sql database. i create a set up file, which is installed with no problems in my computer, but in other computer shows this message:

    Unhandled exception has occumed in your application. lf you click Continue, the application will ignore this emor and attempt to continue. lf you click Quit, the application will close immediately A network-elated or instance-specific emor occumed while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is comect and that SQL Server is configured to allow remote connection provider: SQL Network Interfaces, emor: 52 nable to locate a Local Database Runtime installation. Verify that SQL Server Express is property installed and that the Local Database Runtime feature is enabled.)*

    What i have to do?? how can i fix it??

    my connection string is this:

    add name="QFD_login.Properties.Settings.UsersDatabaseConnectionString"
     connectionString="Data Source
    (LocalDB)\v11.0;AttachDbFilename=|DataDirectory|\UsersDatabase.mdf;Integrated Security=True"
            providerName="System.Data.SqlClient"

    i have tried to change v11.0 to v12.0 but when i did, i couldnt open the app either to my pc. This's the first time i use SQLDatabase i dont know know what to do or how.

    Sunday, November 27, 2016 10:40 PM

All replies

  • Hi,

    make sure that localdb is running.Refer.


    Please Mark it as Answered if it answered your question OR mark it as Helpful if it help you to solve your problem.

    Monday, November 28, 2016 1:12 AM
  • Hi Lk_P,

    >>Verify that SQL Server Express is property installed and that the Local Database Runtime feature is enabled.

    It seems that the issue here is you haven’t installed SQL Server localdb on other computers. In this case, I would suggest you download and install sqllocaldb.msi from this site and try again.

    >>i have tried to change v11.0 to v12.0 but when i did, i couldnt open the app either to my pc.

    From what I see, it’s likely you haven’t installed SQL Server loacaldb 2014(12.0) on your computer. I would suggest you use the command below to verify that.
    Sqllocaldb v

    If you have any other questions, please let me know.

    Regards,
    Lin

    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Tuesday, November 29, 2016 3:15 AM
    Moderator