none
.NET Framework 3.5 Setup Error RRS feed

  • Question

  • Ever since I attempted to install TurboTax 2009, I have been having problems with .Net Framework.  I have Vista 64. I managed to uninstall TT, but .net framework hasn't been right since.  I have tried many of the suggested remedies online as outlined as follows:

    1.  The Aaron Stebner verification tool indicates that Net Framework 2.0 SP2 and Net Framework 3.0 SP2 are correctly installed.  If I run it from the command prompt to specifically see all versions of Net Framework, it indicates that 3.5 is not installed.

    2.  I have tried sfc/scannow.  The first time I tried it (after the Turbotax fiasco) it detected a few errors, which it repaired.  Now when I run it, it detects no errors.

    3.  I have tried turning IIS on and off (it was off originally).  No effect.

    4.  I have tried turning .Net framework on and off.  No effect.

    5.  I downloaded dotnetfxsetup35.exe.  Every time I run the install, even if I run as an administrator, it ends with "setup error," with no other info provided.

    6.  Interestingly, if I run the Aaron Ruckman verification tool for Vista, it indicates that "netfx2.0 sp1 is not installed" and "netfx3.0 sp1 is not installed" and "netfx3.5 RTM is not installed."  The report that 2.0 and 3.0 are missing differs from the Aaron Stebner verification tool as outlined above.

    The effect of all this is that internet windows are slow to open and occasionally crash the computer.  Also, at least one game has a problem connecting to the internet.  PLEASE HELP!

     (By the way, I tried Aaron Stebner's .net framework cleanup utility before later learning that it would not be useful for Vista).

     

     

    Saturday, March 20, 2010 12:51 AM

Answers