locked
"Index (zero based) must be greater than or equal to zero and less than the size of the argument list." RRS feed

  • Question

  • Hi,

    I am getting "Index (zero based) must be greater than or equal to zero and less than the size of the argument list."  this error while opening Link in Work Item through Team System Web Access.

    Wednesday, August 6, 2008 11:27 AM

All replies

  • Hello Rajendra,

     

       Could you please try to download the latest version of TSWA to see if it works?

     

       Thanks.

     

       Here is download link.

     

    http://www.microsoft.com/downloads/details.aspx?FamilyID=c568fba9-3a62-4781-83c6-fdfe79750207&displaylang=en

    http://www.microsoft.com/downloads/details.aspx?FamilyID=2105C9EE-565E-47B9-A5AC-9A8FF8A07862&displaylang=en

     

     

    Tuesday, August 12, 2008 2:31 AM
  • Hi Hua Chen,

     

    I tryed your TSWA versions.

     

    This problem is only with TSWA 2008 and not with TSWA 2005

     

    Tuesday, August 12, 2008 6:53 AM
  • Hi Rejandre,

     

    This is a known bug in Tswa and it is fixed. The fix will be available with Tswa SP1 which is going to be released soon. Thanks for your feedback and patience.

     

    Regards

     

    Serkan Inci - MSDN

     

    Tuesday, August 12, 2008 2:10 PM
  •  

    Hi Serkan,

    Is this fix is included in TFS SP1?

    Is TSWA SP1 is available in next week? If not can I get Fix early before TSWA SP1 release?

    Thursday, August 14, 2008 11:12 AM
  • Raj,

     

    We have been experiencing this also, and have been told for quite some time that the fix will be in SP1.

     

    For your information, this may assist in the short term, we found that the issue relates to a situation where a work item is linked to a work item in another project, and the user doesn't have permissions to that other project.

     

    Our workaround has been to add users who needed to access these work items into the "Readers" group for the linked projects.

     

    Of course, this may not be the case in your situation. Good luck, anyway.

     

    Dylan.

     

    Thursday, August 21, 2008 4:23 AM
  • Thanks Dylan!  Your solution resolved the error for one of our users.
    Tuesday, March 10, 2009 5:59 PM
  • Hi,

    The new version of TSWA should have fixed this issue.

    Regards
    Serkan Inci - MSFT
    Wednesday, March 11, 2009 4:42 PM
  • This issue is not fixed in TSWA SP1. Its alive and well. To clarify, the "issue" as manifested in our environment, is the one outlined by Dylan: Users get the error who don't have permissions to one or more projects referenced by a linked work item.
    Tuesday, March 24, 2009 7:54 PM
  • First of all, we are very sorry for the inconvenience.

    I've just tried the following scenario with the latest version of Team System Web Access and it worked. Please let me know, what am I doing different or wrong here to reproduce this issue.

    Here are my repro steps:

    • User A is Contributor in Project A
    • User A cannot access to Project B
    • There is a Work Item A which belongs to Project A
    • There is a Work Item B which belongs to Project B
    • There is a link between Work Item A and Work Item B
    In my case, User A can open Work Item A successfully. In the links of Work Item A, there is a warning for Work Item B saying that "Unable to access work item B".

    Regards
    Serkan Inci - MSFT
    Tuesday, March 24, 2009 9:49 PM
  • Hi all,
    This is globalisation cluture issue. TSWA 2008 SP1 will not support all langaugages like Finish. If we set the globalisation culture to fi-FI, this error does not come.
    This solved our problem

    Thanks...
    Rajendra, Tieto
    Friday, April 3, 2009 7:15 AM