locked
obtuse COM errors when trying to deploy a windows service RRS feed

  • Question

  • User1072303328 posted

    Not sure if this is the right forum for this... but here goes...

    I've developed a windows service application that uses the FaxComExLib to monitor my faxqueue table in my database, and send/manage the fax queue on my fax server.  I had it running completely fine for over a year. I then moved my database and had to change a simple database connection string in the application. However in that time I switched computers and have so upgraded and compiled it with VS 2010 and .NET 4.

    I use the installutil from the command line to install the service. It installs fine, and I can start it.When I start it however, it throws an error and stops any further processing (although the service remains started)

    I tried installing it on an XP machine and received this error:

    Retrieving the COM class factory for component with CLSID {CDA8ACB0-8CF5-4F6C-9BA2-5931D40C8CAE} failed due to the following error: 80040154 Class not registered (Exception from HRESULT: 0x80040154 (REGDB_E_CLASSNOTREG)).

    When it installed it on the Windows 2003 server that also runs the fax on it, i get this simple error:

    Exception from HRESULT: 0x80040200

    I've googled for days on this and am stuck... I can't get past these errors and get the service running again.

    Well.. almost... I can run it on my Windows 7 development computer... but that is not ideal!

    Thanks.






    Wednesday, November 3, 2010 1:20 PM

Answers

All replies

  • User384031199 posted

    Does it run with the source code in debug mode? 

    Wednesday, November 3, 2010 3:27 PM
  • User1072303328 posted

    I'm not sure how to run a windows service in debug mode from VS...

    When I run it locally... I build and install with the installutil as well and start manually.

    Wednesday, November 3, 2010 3:44 PM
  • User1072303328 posted

    I finally figured out the cause of this error.

    My development machine is Windows 7, it has version 6.1.7600.16385 of the fxscomex.dll.

    I was trying to deploy my windows service to Windows 2003 Server, and Windows XP, which have version 5.2.3790.3959 of fxscomex.dll.

    I did a build on a Windows XP machine and deployed and no more error!


    I am now trying to figure out how to build the service on my Windows 7 machine, but use the previous version of the dll.



    Tuesday, November 16, 2010 11:20 AM
  • User384031199 posted

    Hi,

    I think "fxscomex.dll" for the Microsoft Fax Server COM Client Interface.

    I see a few points in this link that discuss the issues to the programs running in the system especially when this file is damaged.

    http://pcsupport.about.com/od/findbyerrormessage/a/fxscomex-dll-not-found-missing-error.htm

    Hope this helps.

     

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Tuesday, November 16, 2010 1:59 PM
  • User-1636023625 posted

    Hi

     

    I had similar problem when i moved my development environment from xp to win7 and the only and last problem in compiling and having it run good on same client machines was the diference in fxcomex.dll version 6 ( win7 ) to version 5 ( xp ), the interface is different.

     

    how did you solved the  problem in your case ?

     

    M.

    Tuesday, December 21, 2010 5:54 AM