Localhost working LocalIP not RRS feed

  • Question

  • User1045159563 posted
    I'm running IIS on XP Pro.  My website works from my local box if I use either http:\\localhost or http:\\, but it does not work if I use http:\\ (physical IP address).  I've got the XP firewall turned off, but I am behind a router firewall.  I've got port 80 open to the local box.  Any ideas?


    Tuesday, July 25, 2006 11:04 AM

All replies

  • User989702501 posted

    Page cannot be displayed? is IIS binding to that IP or all interfaces? when you do a 'netstat -an' at command prompt, how many ip is listening to port 80? e.g.

    Tuesday, July 25, 2006 11:03 PM
  • User-823196590 posted
    What does "does not work" mean?  What's the detailed error?
    Wednesday, July 26, 2006 9:21 AM
  • User1045159563 posted
    netstat -an shows only listening on port 80.

    The website is bound to 'All Unassigned'.  If I try to create a binding specifically to the local ip I get a 'Binding is not unique' error.  If it's not unique, then why doesn't anything show up in netstat?

    I can telnet to 80 but can not telnet to 80.

    By not work, I mean that in Firefox I get 'Unable to connect.  Firefox can't establish a connection to the server at'  In IE I get 'The page cannot be displayed'.  And as mentioned above, I can not telnet to port 80 on the local ip address.

    Thanks for the assistance.
    Wednesday, July 26, 2006 3:19 PM
  • User989702501 posted
    Interesting.... works but not the server ip. I don't quite understand the error you mentioned when setting the IP binding in IIS MMC. 'binding is not unique' ? can you post the complete error msgs? do you have any other special software install? antivirus, firewall, ? skype? kazzaa ??  it looks like something else is holding the port 80 for the IP.
    Wednesday, July 26, 2006 11:00 PM
  • User-1071573097 posted
    Hi Guys,

    I've had the same trouble with setting up an FTP site on IIS 6.0.

    The error that is mentioned here is in the status column in IIS when the FTP sites (or Web Sites) section is highlighted.

    I can assure you that nothing else is using port 21 in my case and the IP address should not be a problem.

    Any ideas?

    Thursday, August 3, 2006 7:28 AM
  • User-1071573097 posted
    Just a thought ....

    If you are sure there is nothing else bound to the IP address or the port ... try an IISReset from the command prompt.

    simply type iisreset

    Thursday, August 3, 2006 7:51 AM
  • User-823196590 posted
    What error?  There are several mentioned in this thread ...
    Thursday, August 3, 2006 8:09 AM
  • User989702501 posted
    ... let's wait for the OP to clarify...
    Saturday, August 5, 2006 2:41 AM
  • User-255338190 posted



    do like this

    Control Panel -> security --> turn off Firewall  


    if    IIS Ask user password

    Properties int Default Website    -->  Directory Security -> Anonymous Access and authentication control check at  Anonymous Access

    Thursday, October 26, 2006 4:01 AM
  • User-1131243847 posted

    Though I have not gone through entire answers list, but I come across this situation in the following way.

    My web page links are working with locahost but not with any IP or computer name. It does not have any error, especially with GREAT IE (**).

    This was fixed once : I added the site in TRUSTED SITES of IE.

    May be it helps to reduce some frustation...


    Wednesday, January 11, 2012 1:43 AM
  • User989702501 posted

    Adding to trusted sites is not really a good idea, you should find out why it is not working first and why you got prompt for login.

    Wednesday, February 8, 2012 11:27 PM