locked
Disable asking user credentials in windows authentication RRS feed

  • Question

  • User-165297270 posted

    HI,

      In my application i enabled windows and impersonate authentications. If i run my application then it is prompting for windows login credentials, Once i entered windows login credentials visited my application, After few minutes i closed my browser(Chrome/IE) and run the application again at this point of i want to skip asking credentials again. Is there any way to skip the windows login prompt coming again even if i close my browser also(Note : If i disabled impersonate authentication then it is showing unauthorized User).

    Friday, December 16, 2016 1:12 PM

Answers

  • User-460007017 posted

    Hi vinod14,

    To disable the prompt for user credentials, The following condition is necessary:

    1. Enable IIS windows authentication

    2. Client and server are in the same domain

    3.Add the website name to local intranet in IE explorer->internet option->security->click local intranet -> sites ->advanced.

    4.Enable automatic logon only in local intranet in IE explorer->internet option->security->custom level->check Enable automatic logon only in local intranet->OK

    However this configuration only work for intranet user. I think there is no place to ignore windows prompt for remote user.

    Best Regards,

    Yuk Ding

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Monday, December 19, 2016 2:11 AM

All replies

  • User690216013 posted

    https://support.microsoft.com/en-us/kb/258063

    Learn why it prompts and then you can try to disable it.

    Saturday, December 17, 2016 1:25 PM
  • User-460007017 posted

    Hi vinod14,

    To disable the prompt for user credentials, The following condition is necessary:

    1. Enable IIS windows authentication

    2. Client and server are in the same domain

    3.Add the website name to local intranet in IE explorer->internet option->security->click local intranet -> sites ->advanced.

    4.Enable automatic logon only in local intranet in IE explorer->internet option->security->custom level->check Enable automatic logon only in local intranet->OK

    However this configuration only work for intranet user. I think there is no place to ignore windows prompt for remote user.

    Best Regards,

    Yuk Ding

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Monday, December 19, 2016 2:11 AM
  • User-165297270 posted

    Hi Yuk Ding,

    Thank you so much for your quick response.

    Monday, December 19, 2016 5:32 AM