none
IIS Error 500.19 0x80070005 How to fix that? RRS feed

  • Question

  • Has anyone seen that problem and knows what I can do to get rid of it? 
    I had IIS working just fine until I updated this box to Windows 10 Profesional.    Now my local pages show this error: 

    HTTP Error 500.19 - Internal Server Error

    Module    IIS Web Core
    Notification    Unknown
    Handler    Not yet determined
    Error Code    0x80070005
    Config Error    Cannot read configuration file due to insufficient permissions
    Config File    \\?\D:\Sites\MySites\atalkingdog.com.2006\LiveSite\wwwroot\web.config

    I googled the problem and I think the problem is to do with permissions on the user IIS_IUSRS .  So i've made sure that user has full control permissions,  but the problem hasn't gone away. 

    Strangely,  the default page on http://localhost  works ok  and the CF Administrator pages work fine.   It's just my own site that gives this error. 

    Anyone have any hints where I should go now?

    Cheers

    Mike Kear

    Windsor, NSW, Australia.


    Mike Kear, Windsor, NSW, Australia, AFPWebworks Pty Ltd

    Wednesday, January 20, 2016 6:53 AM

All replies

  • you have mentioned IIS_IUSRS group has the permissions.  is that mean you have added this group to the folder share/security permissions?

    and definitely its better to validate the

    1) IIS--> Authentication settings which all are enabled?

    2) select your site from IIS  and click on the Basic settings from the actions pane and click on Test settings and see if Authentication and authorization tests run successfully.

    or you may get further hint on where to go next..


    Thursday, January 21, 2016 10:00 PM
  • 0x80070005
    Server Error in Application "application name"

    HTTP Error 500.19 – Internal Server Error

    HRESULT: 0x80070005

    Description of HRESULT
    The requested page cannot be accessed because the related configuration data for the page is invalid.
    This problem occurs for one of the following reasons:
    • You are using IIS 7.0 on a computer that is running Windows Vista. Additionally, you configure the Web site to use UNC Passthrough authentication to access a remote Universal Naming Convention (UNC) share.
    • The IIS_IUSRS group does not have the appropriate permissions for the ApplicationHost.config file, for the Web.config file, or for the virtual/application directories of IIS.

    Do you check out kb/942055

    To resolve this problem, use one of the following methods.

    Method 1

    Do not configure the Web site to use UNC Passthrough authentication to access the remote UNC share. Instead, specify a user account that has the appropriate permissions to access the remote UNC share.

    Method 2

    Grant the Read permission to the IIS_IUSRS group for the ApplicationHost.config file or for the Web.config file. To do this, follow these steps:

    1. In Windows Explorer, locate the folder that contains the ApplicationHost.config file that is associated with the Web site, or locate the virtual directories or the application directories that contain the Web.config file that is associated with the Web site.
      Note The Web.config file may not be in the virtual directories or the application directories in IIS. Even in this situation, you need to follow these steps.
    2. Right-click the folder that contains the ApplicationHost.config file, or right-click the virtual or application directories that may contain the Web.config file.
    3. Click Properties.
    4. Click the Security tab, and then click Edit.
    5. Click Add.
    6. In the Enter the object names to select box, type  computername\IIS_IUSRS, click Check Names, and then click OK.
      Note Computername is a placeholder for the computer name.
    7. Click to select the Read check box, and then click OK.
    8. In the Properties dialog box for the folder, click OK.
      Note Make sure the folder's properties are inherited by the ApplicationHost.config and Web.config files so that IIS_IUSRS has the Read permission for those files.
    Thursday, January 28, 2016 6:24 PM
  • I can´t find ApplicationHost.config, on the webconfig I´ve added the permissions... nothing works

    Friday, May 25, 2018 6:07 AM
  • my solution is just do to basic settings, click connect as button, and set the specific user: choose which user that allow to access that folder.

    samuel-surya

    Monday, November 26, 2018 4:09 AM
  • Thanks! It really Helped.

    In my case I had changed the username of the machine. The IIS was working fine for a couple weeks until it suddenly stopped wth this error.

    After opening the basic config I selectet "connect as", then I realized the system didnt recognize my actual user name, so I put the old username and same password then it worked.

    Friday, April 5, 2019 12:14 PM