none
Reflect Code Not Working RRS feed

  • Question

  • "Open XML SDK 2.0 Productivity Tool for Microsoft Office" should be able to generate code for generating documents. The Root Node however for the specific Excel file I want to generate does not give me any code (Fig. 1.1) when I hit reflect code however the sub nodes do show code (Fig. 1.2). I tried reflecting code for some other excel files with no problems.

    Is there something I could have done creating the document either adding a password or protecting sheets that would be preventing the reflect code from doing its job? I know I had protected and made hidden a lot of sheets but I tried undoing that protection with the same results.

    I also have =Cell values that refer to other foreign excel files in this workbook could that be the issue?

    (Fig. 1.1)

    (Fig. 1.2)

    Monday, October 21, 2013 7:05 PM

Answers

  • It turns out as you can see at the bottom of the two pictures that the code was simply not yet reflected. On the bottom of the screen for every worksheet that had been completely reflected it says "ready" but at the bottom of the main node as well as the two largest worksheets it still said "reflecting code...". when I let my machine run for awhile 20-30 minutes I was rewarded with the reflected code. sorry I was confused on this.
    • Marked as answer by reigh7 Friday, November 1, 2013 9:18 PM
    • Edited by reigh7 Friday, November 1, 2013 9:19 PM
    Friday, November 1, 2013 9:18 PM

All replies