locked
SignTool Error: Access is denied. when trying to upload app

    Question

  • When trying to create an app package, to certify and uploading an app to Windows Store, I've been getting this error repeatedly:

    Failed to sign 'E:\Completed\Excel_2013_Chart\Excel_2013_Chart\AppPackages\Excel_2013_Chart_1.0.0.1_AnyCPU_Test\Excel_2013_Chart_1.0.0.1_AnyCPU.appx'. SignTool Error: Access is denied.
    SignTool Error: An error occurred while attempting to sign: E:\Completed\Excel_2013_Chart\Excel_2013_Chart\AppPackages\Excel_2013_Chart_1.0.0.1_AnyCPU_Test\Excel_2013_Chart_1.0.0.1_AnyCPU.appx C:\Program Files\MSBuild\Microsoft\VisualStudio\v11.0\AppxPackage\Microsoft.AppXPackage.Targets 1142 9 Excel_2013_Chart

    Have tried:
    1. Creating another account and launching app from it

    2. Aquiring  a  new Developer's Licence

    3. Changing certificate by going to package.appxmanifest > Package tab > Choose Certificate... > Configure Certificate > Create Test Certificate

    4. Changing folder the app files are located in. Tried a short path in C:\ and also 2 others in My Documents

    5. Changing permissions on folder app file in. Gave all accounts Full Control. I know is risky but was getting desperate

    I'm using VS2012 Express. Have been going to menu Store > Create App Packages... then logging in to my Windows Store account & following the prompts.


    Rodger Campbell

    Saturday, May 11, 2013 9:14 AM

All replies

  • Hi,

    Were you able to fix this issue? If so, what did you do?
    One thing I would have tried is to launch VS as administrator...

    HTH,

    Berndt

    Friday, May 31, 2013 2:19 PM
  • Gee sorry Berndt, I thought I replied to your comment a few days ago, must have hit the wrong button & I just looked today & thought "Where's my reply?".

    I did try Shift+rt.click on VS to run as administrator the tried to create an app package but still got the same error. Tried Run as Different User which is also on same menu but could get access.

    I did take a copy of the app to my work computer and was able to create an app package there, Yahoo! So have uploaded that.  But don't want to have to rely on that all the time.

    It seems to be something to do with permissions on this computer.  If you have any other suggestions I'm keen to try them.

    Regards,

    Rodger


    Rodger Campbell

    Wednesday, June 5, 2013 9:03 AM
  • Am opening this up again as the same error has occurred trying to create an app package with updates for the app I've had in the store for awhile.  Now am using VC2012 Pro with update 4 on Windows 8.1.  Everything is completed and ready to upload but this silly permissions message won't let me go any further. Very frustrating!

    When attempting to create an app package: - Project > Store > Create App Packages then sign in, choose a name, choose version number - then the below error shows: 

    Error 1 Failed to sign
    'D:\Completed\Charts_Excel2013b\Chart_Tut_Excel_2013b\Chart_Tut_Excel_2013b\AppPackages\Chart_Tut_Excel_2013b_2.0.0.2_AnyCPU_Test\Chart_Tut_Excel_2013b_2.0.0.2_AnyCPU.appx'.
    SignTool Error: Access is denied.

    SignTool Error: An error occurred while attempting to sign:
    D:\Completed\Charts_Excel2013b\Chart_Tut_Excel_2013b\Chart_Tut_Excel_2013b\AppPackages\Chart_Tut_Excel_2013b_2.0.0.2_AnyCPU_Test\Chart_Tut_Excel_2013b_2.0.0.2_AnyCPU.appx 
     C:\Program Files (x86)\MSBuild\Microsoft\VisualStudio\v11.0\AppxPackage\Microsoft.AppXPackage.Targets 1144 9 Chart_Tut_Excel_2013b

    I sign in with my normal Microsoft account, same one I've got developer's licence with, same one I use always.

    Could it be something to do with the Warnings I get after the error msg?

    I get many warnings related to a related file "MS.AppxPackage.Targets". When looking into this file there are many variables that seem to have not been defined in this file, eg.

    Condition

    ="'$(AppxPackageSigningEnabled)' == 'true'">

    Here is the first warning message if it helps"

    Warning 2 The element 'PropertyGroup' in namespace 'http://schemas.microsoft.com/developer/msbuild/2003' has invalid child element 'AppxMSBuildToolsPath' in namespace 'http://schemas.microsoft.com/developer/msbuild/2003'. List of possible elements expected: 'Property, AllowUnsafeBlocks, AppConfigForCompiler, ApplicationIcon, ApplicationRevision, ApplicationVersion, AppDesignerFolder, AspNetConfiguration, AssemblyKeyContainerName, AssemblyKeyProviderName, AssemblyName, AssemblyOriginatorKeyFile, AssemblyOriginatorKeyFileType, AssemblyOriginatorKeyMode, AssemblyType, AutorunEnabled, BaseAddress, BootstrapperComponentsLocation, BootstrapperComponentsUrl, BootstrapperEnabled, CharacterSet, CheckForOverflowUnderflow, CLRSupport, UseDebugLibraries, CodePage, Configuration, ConfigurationName, ConfigurationOverrideFile, CreateDesktopShortcut, CreateWebPageOnPublish, CurrentSolutionConfigurationContents, DebugSecurityZoneURL, DebugSymbols, DebugType, DefaultClientScript, DefaultHTMLPageLayout, DefaultTargetSchema, DefineConstants, DefineDebug, DefineTrace, DelaySign, DisableLangXtns, DisallowUrlActivation, CodeAnalysisAdditionalOptions, CodeAnalysisApplyLogFileXsl, CodeAnalysisConsoleXsl, CodeAnalysisCulture, CodeAnalysisFailOnMissingRules, CodeAnalysisForceOutput, Co.... C:\Program Files (x86)\MSBuild\Microsoft\VisualStudio\v11.0\AppxPackage\Microsoft.AppXPackage.Targets 5 10 Miscellaneous Files

    If anyone can help, would be great. Can't get the app to store otherwise I think.


    Rodger Campbell

    Wednesday, February 25, 2015 4:21 AM