locked
Issue with SFTP connector RRS feed

  • Question

  • Hi Team,

    I am using SFTP connector in ADF Copy activity for source. It was working correctly getting the following issue from 14th May.

    Using Azure IR, Test connection is successfull. If i try it 30 times it works from 5 times other times i get the following error.

    { "errorCode": "2200", "message": "ErrorCode=UserErrorFailedToConnectToSftpServer,'Type=Microsoft.DataTransfer.Common.Shared.HybridDeliveryException,Message=Failed to connect to Sftp server '**.**.com'.,Source=Microsoft.DataTransfer.ClientLibrary.SftpConnector,''Type=Renci.SshNet.Common.SshConnectionException,Message=Server response does not contain SSH protocol identification.,Source=Renci.SshNet,'", "failureType": "UserError", "target": "CopyMeterReadDataToBlobStore", "details": [] }

    Following are my SFTP linked service settings

    Runtime: AzureIR

    SSH HostKey validation: false

    Authentication type: basic

    Please let me know if there is any solution or alternative

    Wednesday, May 27, 2020 3:36 PM

All replies

  • Hi 

    Thanks for reaching out. Since this looks like intermittent failure, it could be caused by sftp server throttling (max allowed number of concurrent connections setting at SFTP server). Could you please try below alternates to see if that helps. 

    • Increasing the sftp server connection limit to a higher value, e.g. MaxSessions = 50.
    • Since you are using Azure IR please refer to this doc, to allow traffic from the IP addresses listed for the Azure Integration runtime in the specific Azure region where your resources are located (Azure Integration Runtime IP addresses: Specific regions).

    Let us know how it goes. 


    Thank you

    If a post helps to resolve your issue, please click the "Mark as Answer" of that post and/or click Answered "Vote as helpful" button of that post. By marking a post as Answered and/or Helpful, you help others find the answer faster.

    Wednesday, May 27, 2020 6:16 PM
  • Hi

    We have verified the MaxSessions it's 50 and we have Added the IP addresses.

    Still facing this issue with copy activity it works somtimes and it does not work sometimes. on a retry of 10 time i connects 1-2 times

    The SFTP is working fine from Filezilla  with username and password. Any trouble shooting to do on ADF or SFTP level?

    Let me know if you have any suggestions.

    Thanks

    Ravi

    Thursday, May 28, 2020 1:09 PM
  • Hi Ravi, 

    Thanks for your response. Could you please share the below details for deeper investigation of this issue?

    1. Successful - pipeline run ID, activity run ID
    2. Failed -  pipeline run ID, activtiy run ID
    3. Data Factory region

    Thank you

    If a post helps to resolve your issue, please click the "Mark as Answer" of that post and/or click Answered "Vote as helpful" button of that post. By marking a post as Answered and/or Helpful, you help others find the answer faster.

    Thursday, May 28, 2020 7:17 PM
  • Hi Kranthi,

    Following are the details requested. Data factory region is North Europe.

    Successful case:

    PipelineRun ID-7508131e-463a-4f17-a59e-34bd239f0b9d

    Activity Run ID-610678c0-bbf3-4fd3-b7d0-2e093dc8ae45

    Failed Case:

    Pipeline Run ID - 47129a1b-1d4d-4382-9ee5-49ef094334ab

    Activity Run ID - 0b074542-9ec9-4866-bba6-af3b6f97bb5d

    Thank you

    Friday, May 29, 2020 5:44 AM
  • Hi RaviKrishnaJ,

    Thanks for sharing the details. I will look into it and will get back to you as soon as I have an update. 

    Thank you

    If a post helps to resolve your issue, please click the "Mark as Answer" of that post and/or click Answered "Vote as helpful" button of that post. By marking a post as Answered and/or Helpful, you help others find the answer faster.

    Monday, June 1, 2020 3:47 PM
  • Hi RaviKrishnaJ,

    I did initial investigation and reached out to internal team to get more info about this issue. I will keep you posted as soon as I have a response from the team. In case if this is impacting your production, I would recommend you to please a file a Support Request for immediate assistance. 

    Thank you

    If a post helps to resolve your issue, please click the "Mark as Answer" of that post and/or click Answered "Vote as helpful" button of that post. By marking a post as Answered and/or Helpful, you help others find the answer faster.

    Monday, June 1, 2020 8:31 PM
  • Hi RaviKrishnaJ

    After checking with internal team, they would like to double check, if you have successfully white-listed North Europe IP range (20.38.82.0/23, 20.38.80.192/26) -  these IP range should be unblocked.

    Could you please verify and let us know?

    Thank you

    If a post helps to resolve your issue, please click the "Mark as Answer" of that post and/or click Answered "Vote as helpful" button of that post. By marking a post as Answered and/or Helpful, you help others find the answer faster.

    Tuesday, June 2, 2020 10:40 PM
  • Hi RaviKrishnaJ,

    Following up to see if you have got a chance to verify whether North Europe IP range (20.38.82.0/23, 20.38.80.192/26) has been white-listed. In case if you have found a different solution, please consider to share it here with community as it would be beneficial for others. 

    Thank you

    If a post helps to resolve your issue, please click the "Mark as Answer" of that post and/or click Answered "Vote as helpful" button of that post. By marking a post as Answered and/or Helpful, you help others find the answer faster.

    Wednesday, June 3, 2020 8:11 PM
  • Hi Kranthi,

    The following IP ranges should they be configured for inbound or outbound on SFTP server?

    Please let me know.

    Thanks

    Ravi

    Thursday, June 4, 2020 5:19 AM
  • Hi RaviKrishnaJ,

    Thanks for your query. It should be on the inbound of SFTP server. 

    If this does not resolve your issue, please file a support request for deeper analysis. In case if you do not have a support plan, please email below details to AzCommunity@microsoft.com

    Email subject: <Attn - Kranthi : MSDN Thread title>
    Thread URL: <MSDN Thread>
    Subscription ID:  <your subscription id>

    Please let me know here once you have done the same.


    Thank you

    If a post helps to resolve your issue, please click the "Mark as Answer" of that post and/or click Answered "Vote as helpful" button of that post. By marking a post as Answered and/or Helpful, you help others find the answer faster.

    Friday, June 5, 2020 4:36 PM
  • Hi RaviKrishnaJ,

    Just checking to see if your issue was resolved. If you still need assistance, please do share the details requested in my previous comment. 

    Thank you

    If a post helps to resolve your issue, please click the "Mark as Answer" of that post and/or click Answered "Vote as helpful" button of that post. By marking a post as Answered and/or Helpful, you help others find the answer faster.

    Monday, June 8, 2020 11:01 PM