none
Migrating to "The Cloud" - "The SMTP address has no mailbox associated with it." RRS feed

  • Question

  • We have a front office app that can receive data from Exchange via EWS Push Notifications.  Last week, they moved my mailbox to "The Cloud". Now my mail resources all have "office365.com" in their paths. I'm a very early adopter, trying to understand how to extend the app to work with this architecture before they move everyone else over.

    In the past our app was an EWS 1.1 system talking to Exchange 2007 SP1 servers.  That's the ExchangeVersion I've always had set in EWS. Nobody has ever talked to me about upgrading any of our Exchange boxes.  Impersonation was not supported in 2007, so we've been using a dedicated service account with full access to specified mailboxes. At the moment, I'd be happy if I could just connect to my own mailbox with my own credentials.

    Our old system has 4 CAS servers. You can reach a mailbox through any of them.  For the new mailboxes, we've added two new CAS servers. I'm told these particular servers are Exchange 2010 SP3.  I'm also told the cloud mailboxes are in an Exchange 2013 environment.

    I've upgraded my EWS library to 2.2. I've tried ExchangeVersion values for 2007 and 2010 SP2 (there is no value for SP3). I'm not using autodiscover; I just put the name of one of the new CAS servers into the code for now.

    My SMTP address is john.smith@bigcompanyUSA.com. Our internal domain is usa.bigcompany.net, and I commonly login to resources (including my workstation) as USA\smith_j. I was using that ID for Exchange, but since my mailbox got moved I now login to my mailbox as smith_j@usa.bigcompany.net.  We were previously building credentials for EWS with username (smith_j), domain (USA) and password.  Because of the changes, it seems that the right username to pass should now be smith_j@usa.bigcompany.net, along with just the password.

    The problem is that no matter what I send, the server returns "The SMTP address has no mailbox associated with it."  I've tried a lot of permutations, and for hours that's all I've gotten.  Trying to reduce this to the most basic level, what should I be doing in order to reach my own mailbox in office365.com, using my own account?  Is there any trick to this?

    BTW, if Microsoft is using Exchange 2013 and my CAS server is 2010 SP3 which ExchangeVersion should I be using to do this?

    Thursday, January 8, 2015 10:54 PM

All replies

  • Make sure you are connecting to https://outlook.office365.com/ews/exchange.asmx. Either set ExchangeService.Url manually, or use the AutodiscoverUrl method with your *.net email address. And you're right, you should be using the .net address/password for your credentials.

    Hope that helps!

    Friday, January 9, 2015 3:21 PM
    Moderator
  • So are you saying I wouldn't be using my own CAS server for this at all?

    Would that not work, or would it not offer any benefits?

    Do any special permissions need to be configured to reach mailboxes through EWS?

    Oh, and thank you very much for replying. I sometimes forget that, but only because I'm worked up about getting a solution.
    • Edited by Rick.Koch Friday, January 9, 2015 3:26 PM
    Friday, January 9, 2015 3:24 PM
  • This is very good. Using the office365.com URL, I have been able to create a subscription.  Of course, the office365.com server will not be able to make callbacks through our firewall, but it does clearly show that our CAS server is not getting the job done.  This is progress!

    I asked, and was told we're using Exchange 2010 SP 3 on the CAS because we already had licenses for that.

    So I'm back to the question of whether this can be done by an on-premises CAS (or a cluster of them), or if we must go through Microsoft's servers to reach the mailboxes.

    And again, thank you!
    • Edited by Rick.Koch Friday, January 9, 2015 6:10 PM
    Friday, January 9, 2015 6:09 PM
  • You have to go through the Office 365 CAS servers, you can't use your own. Basically in a hybrid setup like that, your on-premise CAS servers can't proxy back to the Exchange Online servers, so you get that "SMTP address has no mailbox" error.
    Friday, January 9, 2015 6:26 PM
    Moderator
  • Thanks.

    This is significant. We rely on push notifications, which means the Office365 CAS servers would need static mappings to my servers, through firewalls, in order to make callbacks. Is that how Office365 client organizations usually do it?

    We have two CAS servers onsite in support of these cloud accounts. They are used for administration tasks. You're quite certain these machines would never be able to handle our push notifications?

    BTW, what ExchangeVersion should I be passing in my EWS service object?

    Friday, January 9, 2015 8:02 PM