locked
changing permission in the registry RRS feed

  • Question

  • A while back I did a registry clean and the program found a bunch of problems which it corrected, since then I´ve had alot of problems with key-permissions when I try to update or install different programs (itunes, adobe...). I get a warning that I dont have access to a certain key in the registry. I´m always signed in as admin. WHen I search out the key in regedit I find that there is no owner, no permissions asigned to the different keys whatsoever. I´ve managed to figyre out how to change the permissions so that I can continue with the installations, however some programs whants access to maybe 10 different keys and its alot of clicking to get it right. I tried to restore the keys that my registry cleaning program deleted but nothing changes.

     

    Is there any way to restore permissions in the registry so that I dont have to manually change them when the problems appear, because I think I´ll have more problems in the future when its time to update other programs.

    Tuesday, October 30, 2007 12:58 PM

All replies

  • How I HOPE someone at Microsoft looks into this problem and answers soon!

     

    I have a great many registry keys that are locked with NO permisions possible, even to admin.

    tried lots of stuff to find and modify them.

     

    Sysinternal's (now MSFT) Wonderful  AccessEnum program finds them and where the Read  Write  Deny columns for other keys say Admin or NT Authority, etc, the locked keys just have "???".  Nothing I have found INCLUDING the subinacl and reset.cmd  -> all registry permissions to default.  I've run this many times after regediting to no avail.

     

    Most of the keys are written by Skype, Google Earth, Adobe, and Apple Quicktime.  Which also happen to be common targets for trojan programs....

     

    The biggest problem that these locked keys create is that if you need to rollback an installation of say Quicktime (due to this latest 7.3 mess)  you can't re-install any previous versions because the keys are locked.

     

     

    Saturday, December 1, 2007 6:39 AM
  • though i really can't explain it well, this snip below FIXED the problem

    what it comes down to is the keys are owned by the SYSTEM which you can't normally sign in as....

    (and all these fantastic utilities:  THANK YOU  Mr Russinovitch !)

     

     

     

    microsoft.public.windows.vista.security

    From regedit, you should be able to take ownership of the key, and then
    change the key's security settings.

    Alternatively, you can download the following tool from microsoft to open an
    instance of regedit as system:

    http://www.microsoft.com/technet/sysinternals/utilities/psexec.mspx

    The following command line will open a "system" regedit:

    psexec -s -i regedit

    (Note: You have to execute this command line from an "administrator" command
    prompt [right-click command prompt and click run as administrator])

    --
    - JB
      Microsoft MVP Windows Shell/User

     

    Saturday, December 1, 2007 11:42 AM