none
Biztalk Send port with WCF-SAP adapter is failing with 'Unknown Error Description' error RRS feed

  • Question

  • Hi,

    Looking for some suggestions on this 'Unknown Error Description' error warning logged in Biztalk event log. This is logged when WCF-SAP adapter send port is failing to send idoc's to SAP system looks like but weird thing is when this happens the idoc is still successfully delivered to SAP system but then the same idoc is resent to SAP 2nd time so basically Biztalk is sending the same idoc twice creating duplicates in SAP system as well archiving in biztalk twice.  Searched for such similar issues and found this error is generic one and not specific to SAP adapter. 

    I also found that Retry on Send port might also cause this error of duplication so setting it to 0 should resolve, however if thats done then in case of failure messages suspend and need manual triggering i suppose but if this resolves the issue is this approach recommended? Please suggest.

    This is really causing issues on our production systems and not sure what could resolve this . If anyone has faced similar issue please suggest. Thank you. 

    Thursday, March 29, 2018 10:27 AM

All replies

  • Hi,

    First you should get some information for the unknown error message.

    You said you have two archives? how you are performing the archives? can you confirm that retry is sending two times the files if retry is sending duplicate files then you should two instances inside BizTalk.

    Regards,

    Sharad  

    Thursday, March 29, 2018 12:07 PM
  • Hi Sharad,

    yes, biztalk is archiving the file twice i.e. one archived and sent out to SAP at the same time as the file is received in biztalk and then in a few seconds of difference above warning is logged to event log and then after 5mins of received time the same file is archived again in biztalk and sent out. so receiving just one file in biztalk   but sending and archiving 2 copies of the file.

    ex: receiving  the file in BT at 12:25pm today and can see the file archived in biztalk at 12:25 and sent out to SAP system then I see warning logged around 12:25:11pm and can see the same file archived again in biztalk at 12:30pm and sent out to SAP. 

    The warning is logged some times in the 2nd Biztalk server and sometimes in 1st server as we have got 2 biztalk PROD servers running. 

    Thursday, March 29, 2018 12:40 PM