locked
VS2008 Datadriven Test fails using Oracle DataSource RRS feed

  • Question

  • Hi

    I try to use an Oracle (10g) Table as datasource of an datadriven UnitTest in VisualStudio 2008. The test seems to connect to the Oracle DB (fails on wrong credentials), but then fails with error "The unit test adapter failed to connect to the data source or to read the data, ....

    Error details:

    System.IndexOutOfRangeException occurred
    Message="Der Index war außerhalb des Arraybereichs."
    Source="Microsoft.VisualStudio.QualityTools.Common"
    StackTrace:
    bei Microsoft.VisualStudio.TestTools.Utility.TestDataConnectionSql.FindIdentifierEnd(String text, Int32 start)
    InnerException:


    I use the following attributes:

    <TestMethod()> _
    <DataSource("Devart.Data.Oracle", "user id=xxxxx;password=xxxxxx;server=szhm2257.stzh.ch;home=OraClient10g;direct=True;sid=ZPL10RT;persist security info=True", "TBLLAYER", DataAccessMethod.Sequential)> _
    Public Sub OoiDataManagerGetAllPoiDetails_ValidObject()

    Client OS is Windows7 (64bit)

    Using VS2008 ServerExplorer I can connect to the oracle DB read/write Data using Provider 'dotConnect for Oracle' (Devart.Data.Oracle) without any problem.

    Is there any solution or workaround.

    Any help is very much appreciated.

    Best Regards


    Bernd Nierula
    Thursday, February 25, 2010 11:00 AM

All replies

  • Hello Bernd,

    Have you tried with VS 2010 RC?

    Thanks,
    David Gorena Elizondo
    [MSFT] Visual Studio Team Test
    Friday, February 26, 2010 7:35 PM
  • Hello, Bernd.Have your problem solved? I think the problem is the calling instead of the configuration. Can you give more information?
    Senior Programmer | iPod Killer Fan
    Wednesday, June 16, 2010 12:39 PM