none
Separate Association and Initiation forms

    Question

  • Hi,

    I have a workflow that uses three forms, one for association, one for initiation, and one for edit task.  When I first associate the workflow with a list, the association form opens correctly with the pre-defined association data that I passed to it.  The problem is, when I try to instantiate the workflow on a particular document in the list all I get is the message, "The form has been closed."  When I looked in the logs it looks like the Initiation form is looking for the association schema and not finding it.  I know the association data is passed to the initiation form, but if the schema is available for opening the association form why isn't it available to open the initiation form?  Is there something I'm not specifying in the workflow.xml file?  Below are the errors in the log.

    Thank you,

    Cynthia

    Services Runtime         82fv Critical The form template failed to load. (User: ***: WFInitiation, IP: , Request: http://***/_layouts/IniWrkflIP.aspx?List=6f25f7bd-255c-41e1-99bd-8934505749e3&ID=3&TemplateID={7df6e29f-abdf-4102-a829-525de1ac2006}&Source=http://***/CynthiasWorkflow%2520Test/Forms/AllItems.aspx, Form ID: urn:schemas-microsoft-com:office:infopath:WFInitiation:-myXSD-2007-01-15T21-41-05, Type: SchemaValidationException, Exception Message: Could not find schema information for the element 'http://schemas.microsoft.com/office/infopath/2003/myXSD/2007-01-25T23:33:14:AssociationForm'.) a8166ff7-3ae1-4964-8903-a1f8423c1a1a
    01/26/2007 12:56:32.65  w3wp.exe (0x0F6C)                        0x0D20 Forms

    Server                   Forms Services File Open       7tev Medium   Form load failed with a validation error a8166ff7-3ae1-4964-8903-a1f8423c1a1a

    Friday, January 26, 2007 8:17 PM

Answers

  • Hi

    I had the same issue with the scema error and have solved it, i have posted the details on my blog at http://zgud.spaces.live.com/ but in short:

    A) To get the same scema you first create one form and then use save as to make the second.

    B) Another solution is to use the same form and show/hide different sections depending on what form you are showing.

    Monday, January 29, 2007 10:18 AM

All replies

  • Hi Cynthia,

    If you figured out the problem, would you mind to post the solution? I'm having exactly the same issue and am pretty much beating my head against a wall trying to figure it out. :-)

    Thanks,

    Matt

    Sunday, January 28, 2007 8:17 PM
  • Sorry, I still haven't had any luck.  Here is what I've tried so far.  I copied the schema from the IP form into the FEATURES file (I know it's already there as part of the form's xsn file, but you never know).  I tried using the default name IP gives it (myschema) and I also tried naming it to match the name of the IP form.  I also went back and named the fields collection in the IP form to match the name of the form.  I had them named differently, but I noticed in the logs it was looking for the schema of the fields collection's root element so I thought maybe it was getting lost since the IP template had a different name.  None of this worked and I've run out of ideas.  If you figure this out, please let me know, I'm also 'beating my head against a wall' on this one. :-)

    -Cynthia

    Sunday, January 28, 2007 10:23 PM
  • Hi

    I had the same issue with the scema error and have solved it, i have posted the details on my blog at http://zgud.spaces.live.com/ but in short:

    A) To get the same scema you first create one form and then use save as to make the second.

    B) Another solution is to use the same form and show/hide different sections depending on what form you are showing.

    Monday, January 29, 2007 10:18 AM
  • Hi Gudjon,

    That solved the problem.  Thank you for your help, I never would have thought of trying that.

    -Cynthia

    Monday, January 29, 2007 8:29 PM
  • Hi guys, I have a question.

     

    is it possible to use more the three IP forms? For example, I want to use a IP form for approve process and IP forms for enter data or the IP form that will show depended in who open the task item.

     

    Example

     

    Secretary will fill out the first form (IP form 1)

    Administrator will fill out the financial information (IP form 2)

    approvers will Accept or reject (IP form 3)

    The legal department will fill out any legal data (IP form 4)

     

     

    Thanks

     

     

     

     

     

    Tuesday, October 2, 2007 6:52 PM
  • Ok, so its now feb 15th 2008 and I have the exact same problem and your solution works (kind of). That said, we have decided to go the safe route and use just an Init form.

     

    Am I to understand that this has been a problem for more then a year now and VS08 is about to get released to everyone next week with this bug? Isnt this kind of a major bug for this type of project? Am I missing something?

    Friday, February 15, 2008 4:31 PM
  •  

    I have the same problem but haven't figured out how to use the work around with the "Save as" in Visual Studio 2008. So what? Do I really have to stick to InfoPath 2007 to create my initiation and association form?! That is more then annoying! As Sean said, it's a major bug.
    Thursday, February 21, 2008 7:59 AM
  • The link is not working. Can you share the code please

    Venkata Ratnam

    Wednesday, March 27, 2013 1:22 PM