locked
Building Solution is a success, but when I run the solution in an emulator, it says build fails. RRS feed

  • Question

  • User365006 posted

    Build Failed: Xamarin.Android does not support running the previous version. Please ensure your solution builds before running or debugging it.

    No errors in the error list, not sure what I'm supposed to do at this point.

    Saturday, January 27, 2018 8:22 PM

All replies

  • User365022 posted

    Hey man,

    I had a similar problem and this fixed it: - Next to "Debug", if you have " Any CPU", Click on it and select "Configuration Manager" - You will see "Debug" and "Any CPU" again, click on "Any CPU" to open a dropdown list and choose the option "x86" - Then whenever you are running your App just make sure that x86 is selected next to "Debug"

    I hope this helps!

    Cheers, Ruben

    Sunday, January 28, 2018 3:45 PM
  • User366645 posted

    Thanks ruben_fonte, this helped me.

    Monday, March 26, 2018 2:39 AM
  • User24062 posted

    I am getting this all the time with version 15.7.3 of VS 2017. Debug versions will run and Release won't. This even on solutions that built Release versions previously. Selecting x86 didn't help nor ARM for ARM emulators. It's like they rushed 15.7.3 so they could take an early summer vacation (very common in corporate America). This is very frustrating when trying to release an update for my customers. No builds including just simple ones want to work in release mode.

    Sunday, June 17, 2018 8:42 PM
  • User24062 posted

    Turns out we now have to sign the ARM version. I don't recall any need to this before just AdHoc and Google Play versions needed to be signed and you were prompted for those. BTW, I still get the message but the app runs (LOL).

    Sunday, June 17, 2018 10:41 PM
  • User252595 posted

    @ruben_fonte said: Hey man,

    I had a similar problem and this fixed it: - Next to "Debug", if you have " Any CPU", Click on it and select "Configuration Manager" - You will see "Debug" and "Any CPU" again, click on "Any CPU" to open a dropdown list and choose the option "x86" - Then whenever you are running your App just make sure that x86 is selected next to "Debug"

    I hope this helps!

    Cheers, Ruben

    Thanks @ruben_fonte!

    Thursday, March 21, 2019 12:41 AM
  • User389009 posted

    Hello. Thats Not working for Me. like debug on "x86"

    Wednesday, September 11, 2019 12:57 PM
  • User388067 posted

    Hi @Rahul_rathaur Have you resolved the above issue, If yes, please let us know how to resolve that which will be great help for us.

    Thursday, September 19, 2019 5:23 AM
  • User388067 posted

    Hi @Dysprosium ,

    Have you found any solution for the issue which you posted. If yes please share that so that it will be very helpful for me because even I am facing the same problem and trying to solve that but no use.

    Thursday, September 19, 2019 10:28 AM