Update to address Win 8.1 apps on Win 10 1809+ RRS feed

  • General discussion

  • We have an updated Kinect for Windows driver + runtime as well as an updated platform extension that addresses issues using Win 8.1 store apps with Kinect for Window on Win 10 1809+.  These updates do not impact any other scenario, and you only need to manually install these updates if you are using Win 8.1 store apps on Win 10 1809 or later

    The platform extension is not yet available via the Microsoft Store, and the driver + runtime update is currently available through Windows Update for PCs opted into either the fast, slow, or release preview Windows Insider rings. 

    If you like, you can try out these updates right now by doing the following (any feedback is greatly appreciated):

      1. Make sure you are on Windows 10 1809+ (x64)
      2. Install the updated driver + runtime either via windows update (PCs opted into Windows Insider fast/slow/release preview rings) or by downloading directly at:

        If you download from the link above, please make sure you install by right clicking on kinectsensor.inf and selecting “install” (Do *not* run KinectRuntime-x64.msi directly).

      3. Download the updated platform extension here:
        To install the platform extension, extract the .zip file and double click on each of the .appx packages.  Make sure you install both packages.
      4. After both updates are installed, you will need to grant both webcam and microphone permissions to a Win 8.1 app before it can access the Kinect.

    If you are still having trouble using the Kinect V2 and Win 8.1 apps on Win 10 1809+ after following the above steps, please let us know.


    Tuesday, August 13, 2019 2:06 AM

All replies

  • Thank you so much for this fix!!
    I can confirm that Kinect now works again with the Windows Store 8.1 apps, checked on two different systems.
    However on one laptop the installation was not straightforward, I can describe the problem if someone else run into smth similar.
    For the first zip, the Kinect Sensor driver installed as it should immediately, but the Runtime (in that zip) did not seem to update.
    This is what the system said first.
    In Device Manager, for WDF Kinect Sensor Interface 0
    Driver version 2.2.1905.16000
    (So that was OK.)
    In Settings, Apps, "Kinect for Windows Runtime v2.2_1811
    (So no update there.)
    (Also listed was Kinect for Windows SDK v2.0_1409)
    Something seemed to be blocking the Kinect Runtime update. First I got the drivers from opting in on Windows Insider Slow, and noticed the driver seemed to get downloaded pretty quick, In update history it said: Microsoft - KinectSensor - 5/16/2019 12:00:00AM - 2.2.1905.16000, but the apps didn't work.
    I then tried to manually download the zip from the link (during that I got some message about "User System has previously initiated an install for product ASUS Smart Gesture".., don't know if it was some other update that had hanged). Still didn't work. Then I manually uninstalled the old "Kinect for Windows Runtime v2.2_1811" from Settings - Apps, and ran the kinectsensor.inf again, rebooted. Now it worked.
    So now it reads:
    In Device Manager, for WDF Kinect Sensor Interface 0
    Driver version 2.2.1905.16000
    In Settings - Apps
    "Kinect for Windows Runtime v2.2_1905
    Superhappy we now can run the games again. Great job!
    Wednesday, August 14, 2019 11:44 PM
  • Very good news,

    following your way at the moment I still can't make my kinect back to work.

    Do you have the "Kinect for Windows SDK v2.0_1409" installed? I do

    Monday, August 19, 2019 10:28 AM
  • Yes, "Kinect for Windows SDK v2.0_1409" is installed in both systems that were tested.
    Visible under System - Apps, and in Start Menu.

    (A bit beside the point, something has happened with the SDK Sample Browser, samples no longer look installed, but that happened some time ago, guess some of earlier update, opening the separate Kinect Studio still works, and don't think it is related to this.)

    Monday, August 19, 2019 11:14 PM
  • Daffanc -

    What issue are you seeing?  Is the Kinect just not working with Win 8.1 specifically, or does it not work at all for you?


    Thursday, August 22, 2019 2:32 AM
  • Nick -

    It sounds like you might be hitting an issue that can happen where after manually uninstalling the Runtime, the SDK Browser can no longer find the samples.  You can fix this by re-installing the SDK:

    1.  Uninstall the SDK from the Apps & features panel in the settings app

    2.  Re-install the SDK (

    3.  After reinstalling the SDK, you'll be back on the driver version that comes with the SDK, and to update back to the latest you'll need to go to Device Manager, "Kinect sensors devices" -> "WDF KinectSensor Interface 0" -> Right click -> "Update Driver" -> "Search automatically for updated driver software", and you should be back to the right driver version and the SDK Browser should be able to find the samples again.

    Let me know if this doesn't work for you or you see any other issues.



    Thursday, August 22, 2019 2:41 AM
  • I'm on Windows 10 x64 Pro 1903 (OS build 18362.295).

    I used the steps provided:

    1.  Uninstall the SDK from the Apps & features panel in the settings app

    2.  Re-install the SDK

    3.  After reinstalling the SDK, you'll be back on the driver version that comes with the SDK, and to update back to the latest you'll need to go to Device Manager, "Kinect sensors devices" -> "WDF KinectSensor Interface 0" -> Right click -> "Update Driver" -> "Search automatically for updated driver software", and you should be back to the right driver version and the SDK Browser should be able to find the samples again.

    No one application can see or activate (kinect light always off) the Kinect Device. It worked on this pc until version 1803.

    An intereseting thing is that after the last big win10 update the device worked till the next reboot...

    Sunday, August 25, 2019 1:25 PM
  • Daffanc -

    What is the make/model of your PC?

    Note - reinstalling the SDK is specifically to solve the problem of the samples not working from the SDK browser.  I wouldn't expect that to help if the Kinect isn't working at all for you.  Apologies if that wasn't clear. 


    Sunday, August 25, 2019 6:33 PM
  • Hi Bryan,

    it was clear, don't worry about that.

    Mine is a generic assembled PC with an additional PCIe USB 3.0 where Kinect has always worked well till the win 10 1809 update ("worked well" means: it is visible in devices manager list, SDK browser and Kinect configuration verifier OK, games and apps OK).

    From update 1809 Kinect is still visible in Device Manager list as usual, but no one application can activate it. So I'm waiting from that moment for an update that brings me back the possibility to use my original Microsft device on my original Microsoft OS.

    Edit: with "Activate" I mean that the device turns on its lights and sensors on the front

    Thank you again for the effort you are putting in this problem

    • Edited by Daffanc Monday, August 26, 2019 8:38 AM
    Monday, August 26, 2019 8:32 AM
  • Daffanc - 

    Can you check the following for me:

    1. Driver version:  Open device manager, right click on WDF KinectSensor Interface 0 -> properties, select the driver tab, and report the # given for "Driver Version".
    2. Runtime version:  Open the settings app -> Apps, find the app labeled "Kinect for Windows Runtime v2.x_xxxx", and report the actual version number.



    Monday, August 26, 2019 11:21 PM
  • Sure.

    Driver Version: 2.2.1905.16000

    Kinect for Windows Runtime v2.2_1905

    Tuesday, August 27, 2019 9:12 AM
  • Daffanc -

    There's no known issues that would prevent that version of the driver/runtime from working on 1809, so I'd like to dig into this a bit further.

    What happens if you try to open the Kinect in the "Camera" app?  I just want to double check that you don't see any image at all or any lights on the device (in which case it could be an issue with your microphone permissions).

    Does your motherboard have a built in USB3 that you can try?

    What's the specific model of your USB3 PCIe card?

    Can you open Task Manager -> Details tab, and check the following:

    1.  There are exactly one instance of both KinectMonitor.exe and KinectService.exe running.

    2.  What user is KinectService.exe running as?

    3.  For both KinectMonitor and KinectService, "Right Click" -> "Properties" -> "Details" Tab, and verify that the "File Version" is 2.2.1905.16000.



    Tuesday, August 27, 2019 8:42 PM
  • Trying to open the Kinect in the "Camera" app i receive the following error:

    0xA00F4291<VideoPreviewStartFailed> (oxC00D3704)

    My maotherboard has as ASMedia 3.0 Usb that I had to disable to let Kinect work in the past.

    I have one Rosewill RC-505 and one M-Cab 7100090.

    In task manager I see KinectMonitor.exe (version 2.2.1905.16000) running by user SYSTEM

    In task manager I CAN'T see KinectService.exe !!! << EUREKA!!!

    In task manager I see KStudioHostService.exe (version 2.0.1410.19000) running by user MY_USER

    Starting KinectService.exe from C:\Windows\System32\Kinect brings all back to work !!!

    Now, why this process was not started? Can I do something to make it starting at boot time as KinectMonitor service?

    • Edited by Daffanc Wednesday, August 28, 2019 1:55 PM
    Wednesday, August 28, 2019 1:27 PM
  • Daffanc - 

    That would explain why no app was able to see the Kinect.  KinectService.exe should be automatically started when you log in, and restarted within a few seconds if the process gets terminated so I'd like to try and figure out why that's not happening in your case.

    1.  Are you using the Kinect with Windows Hello (i.e. logging in via face sign-in)?  If so, did this break as well after updating to 1903?

    2.  If you manually terminate KinectService.exe (e.g. by selecting it in task manager and hitting 'del') after you've manually started it, does it get restarted automatically?


    Wednesday, August 28, 2019 10:10 PM
  • 1. No

    2. it does not restart (it does not start automatically at log in time, it does not compare in services)

    edit: at the moment I solved the situation adding a task in Task Schedluer to start the KinectService at "logged-in" time

    • Edited by Daffanc Wednesday, September 4, 2019 2:39 PM
    Thursday, August 29, 2019 6:40 AM
  • Hello Bryan,

    I use Dell Precision M3800, Windows 10 pro, Intel Core i7-4712HQ CPU @2.30GHz, 16 GB RAM

    Version 1903, System Build 18362.329

    The Kinect One will be not detected.

    The Task Manager show sporadic the KinectService.exe.

    That mean that I see the "KinectService.exe" only for a short time. Status is deactive.

    The entry is available for 2 seconds, and is not visible for 5 seconds.

    2 different Kinect was tested. both show the same behavior.

    USB device will be not detected

    Idears are welcomme to solve the problem

    Thursday, September 5, 2019 5:09 PM
  • Hi Bryan, 

    Wanted to see if there was any development on these. 

    We're currently experimenting with the Kinect V2 as well and downloaded some app both from the store and from Mixxusstudio. And most of them do not work. I've followed the instructions above and see the same entries in Device Manager and App/Programs (in terms of version). I can also see the Kinect Services and 2 other tasks running in task manager. We can also run the kinect using Kinect Studio. But for the other apps, they just don't work. 

    Just checking to see if there's been any other developments regarding this. 


    Thursday, November 28, 2019 3:19 AM
  • Mel -

    Can you go to the "Settings" app and make sure that the apps you are trying have permission to use both the microphone (Settings->Privacy->Microphone) and webcam (Settings->Privacy->Camera) and that the settings for "Allow desktop apps to access your microphone" and "Allow desktop apps to access your camera" are both enabled?  

    Is there a specific app that's still not working for you even after verifying the permissions?


    Friday, December 6, 2019 11:18 PM
  • For those who may still have troubles with this (a few had), I've made a short tutorial with images that may help.
    Friday, May 15, 2020 4:20 PM