locked
An error has occurred while attempting to load the Crystal Reports runtime

    Question

  • I am trying to connect to a VS 2005 MDF database. It appears that the only way to connect to it is through a datset. Is this right?

    But when I try to use the report, I get the following error at runntime:

    ---------------------------
    Crystal Reports
    ---------------------------
    An error has occurred while attempting to load the Crystal Reports runtime.

    Either the Crystal Reports registry key permissions are insufficient or the Crystal Reports runtime is not installed correctly.

    Please install the appropriate Crystal Reports redistributable (CRRedist*.msi) containing the correct version of the Crystal Reports runtime (x86, x64, or Itanium) required.  Please go to http://www.businessobjects.com/support for more information.
    ---------------------------
    OK  
    ---------------------------

    Any ideas?
    Dave

    Wednesday, November 16, 2005 7:01 PM

Answers

  • I forgot that Crystal Reports does not initialize with x64 configuration. I changed the configuration to x86 and it now initializes.

    Dave
    Thursday, November 17, 2005 4:47 PM

All replies

  • Yes, you can connect this type of database through a dataset.  We have to narrow down the problem.  Can you please check if dataset itself is working without Crystal Report components?

    Wednesday, November 16, 2005 9:16 PM
    Moderator
  • Yes, the dataset works fine by itself.

    The error occurs on the constructor of the report. I just installed the release version of DevStudio 2005.


    public class SystemLogReport : ReportClass
    {
    public SystemLogReport()    <---Error here
    {}

    public override string ResourceName
    {
    get {return "SystemLogReport.rpt";}
    set {// o nothing}
    }

    ...
    }

    Is there another way to connect to the SQL Express database other than through a dataset?

    BTW, I am running Windows x64.

    Dave
    Wednesday, November 16, 2005 11:04 PM
  • I forgot that Crystal Reports does not initialize with x64 configuration. I changed the configuration to x86 and it now initializes.

    Dave
    Thursday, November 17, 2005 4:47 PM
  • How do I change the Configuration to x86??
    Thursday, December 15, 2005 5:05 PM
  • Hi Dave - please give us more detail on what you mean by 'Crystal Reports does not initialize with x64 configuration'....

     

    Thanks!

    Mike

    Wednesday, February 01, 2006 7:20 AM
  • Dave, I am experiencing the same error.  Could you elaborate on changing the initialize configuration from x64 to x86?  Thanks in advance!

     

    Tim

    Sunday, May 21, 2006 7:51 PM
  • could you please explain. are you talking about the compile configuration?

     

    -Duane

    Wednesday, June 28, 2006 7:05 PM
  • Go to your application project, right click, and select "Properties"

    On the Build tab, find the Platform Target combo box. It probably says, "Any CPU". Change this to x86 and your project will compile for 32 bit only, thus eliminating the issue.

    This fixed my problem - and my sincerest thanks. Crystal Reports sucks, Reporting Services rules!

    • Proposed as answer by Babble0n Tuesday, June 29, 2010 9:56 PM
    Tuesday, August 29, 2006 8:23 PM
  • Hi Folks,

    i had a lot of issues with this one as well, I am using Crystal report 11.  My issue was that VB.Net 2005 does not show the Crystal 11 dlls under the .Net tab, so when I added the 10.0 references it would throw the error.  I removed the 10.0 dlls from the references then went to the browse tab and added the same dlls from the folder C:\Program Files\Common Files\Business Objects\3.0\managed.


    Friday, October 19, 2007 1:53 AM
  • hi thk u Shaun Hayward . it wrked fine for me. 

     


    Tuesday, April 06, 2010 2:16 PM
  • Hi All,

    I have so many Crystal reports, around 80-100, created in Crystal report XI using Oracle 10g and deployed on Crystal report server XI.

    Now client has upgraded all the softwares from 32 to 64 bit like

    Windows server 2008 64 bit

    Crystal Report 2008 64 bit

    Crystal report 2008 server 64 bit

    Oracle 11g 64 bit.

    I have installed Crystal report server and tried to deploy my existing reports. All reports have been deployed along wth database configuration details. But When I tried to view these reports it throws an error "sample.rpt : unable to load database information"

    I checked everything like TNS, oracle connectivity etc.

    Will anybody let me know the solution for the same?

     

    Thanks in Advance

    Sanjay

    Tuesday, April 13, 2010 1:02 PM
  • That's fine - if you are compiling an application.  However, it doesn't work so well for a web site.  Do this to fix a website:

    Follow the steps for "Global Settings" to make the change for all applications on your server.  To do one application, then follow the application-level steps.  Common sense... :)

    This is due to CR being a 32-bit app running on a 64-bit server.  The server needs to be configured to run 32-bit apps in 32-bit mode.  This is an issue that is not unique to Crystal Reports.  To configure the server to run 32-bit apps, due the following:
    Global Setting:
    Go to IIS
    Select the server (e.g.: MyServerName)
    Select Configuration Editor
    You will see a drop-down combo box titled “Section:”.  Click on it.
    Select system.applicationHost/applicationPools
    Expand applicationPoolDefaults
    Set enable32BitAppOnWin64 to “True”

    Application-level setting:
    Go to IIS
    Click on “Application Pools”
    Select the application you want to modify (e.g.: SuperApp)
    Right click on that application
    Left click on Advanced Settings
    Set Enable 32-Bit Applications to “True”

    • Proposed as answer by J Fischer Friday, July 02, 2010 3:45 PM
    Friday, July 02, 2010 3:44 PM
  • If you are using ODBC, then make sure you use the 32-bit odbc, not the standard 64-bit on x64 systems.  The 32-bit ODBC is available from %systemdrive%\Windows\SysWoW64 folder.  http://support.microsoft.com/kb/942976/en-us?wa=wsignin1.0

    This helped to resolve my problem, hope it helps others

    Monday, July 05, 2010 4:23 PM
  • Hi there,

    I am having the same issue on my Visual Studio 9 and Windows 2003 64 bit server. I am trying to run my crystal report which was developed on 32 bit server. But my all other application runs under64 bt and i cant change it back to 32 bit. Is there a way i can accomplish this without changing it to 32 bit?

    Thanks in advance and any help would be greatly appreciated.

     

     

     

    Tuesday, July 06, 2010 2:23 PM
  • I had same problem, I couldn't find x86 in Platform, this helped me http://social.msdn.microsoft.com/Forums/en-US/Vsexpressvb/thread/129ad858-0204-45d1-8a19-63755ab829eb/
    Monday, August 23, 2010 11:30 AM
  • This is a fantastic bit of info for developers new to 64-bit desktops.  Fixed my Windows-7-64bit/IIS7/CR2008 problem straight away.

    Thanks J Fischer!

    Wednesday, August 25, 2010 4:41 PM
  • J Fischer for President!

    Thanks a lot. This tip will solve ongoing problems with several of my applications.

    • Proposed as answer by Shahbaz Wasti Wednesday, October 27, 2010 5:57 AM
    Monday, October 11, 2010 7:08 PM
  • thanks yar mine is working now :-)
    • Proposed as answer by Jamal Khan Tuesday, October 26, 2010 11:53 AM
    Tuesday, October 26, 2010 11:52 AM
  • thanks yar mine is working now :-)

    I have solved this problem here is the solution in VS 2005

     

     Go to Project Properties--> Select Compile Tab-->Click Advanced Compile Options --> Select x86 platform from Target CPU

    This worked for me hopefully work for you as well

     

    Wednesday, October 27, 2010 5:59 AM
  • hi,

     

          how to configure to x86 pls tell me.  its urgent pls....

    Friday, January 14, 2011 6:24 AM